How to setup IPFS desktop with repository in external HD

Before installing the desktop, I planned for the repository to be located on an external HD at e:\ipfs. Added that directory to the path. Also set IPFS_PATH=e:\ipfs. Installed IPFS desktop 7.2 with Windows 7 OS. Appears OK, but repository is on C:…ipfs default. Exited IPFS and copied contents of .ipfs directory to e:\ipfs hoping it would revert to that location when reopened. After opening PFS desktop the lock engaged at c:…ipfs indicating no recognition of e:\ipfs.

IPFS desktop is set to not automatically open. It will only be opened after the VPN and external HD are active.

What am I missing here to have IPFS repository at external HD e:\ipfs?

1 Like

How and where?

If I set IPFS_PATH as a user environment variable, the setting is respected.

Similar to you as shown, but with Win7

Are you using IPFS Desktop?

Not usually, but I tested with both go-ipfs and IPFS desktop.

I changes e:\ipfs to E:\ipfs just in case the drive letter case was the problem. No luck. Still activating repo.lock at C:…ipfs\ . Puzzling…

Is there any chance that IPFS desktop is running as a different user? If so, maybe try setting IPFS_PATH as a system variable instead of a user variable (?).

Eliminated e:\ipfs from path with no luck. Now setting system variable as suggested.

Added system variable IPFS_PATH=E:\ipfs with no success. Now leaving that and deleting user variable for the next try. Each iteration on this old box is agonizingly slow. Glad IPFS doesn’t require much of a processor.

System variable IPFS_PATH=e:\ipfs only, with no user variable and no path to e:\ipfs still doesn’t apparently work. repo.lock is still activated at C:\ … .ipfs and not at E:\ipfs . Very puzzling. Calling it a night to sleep on it. Any other suggestions will be much appreciated. Hoping to put a few Tb to work for IPFS.

Will repo.lock still activate at C:\ … \ .ipfs if IPFS desktop is accessing \block at E:\ipfs ? How can I determine with IPFS Desktop where the active repository is located?

Finally figured out how to move repo directory to external HD E:\ipfs and have it recognized by IPFS Desktop, after previous install with repo on OS HD at default location.

  1. System Variable (not user variable) set IPFS_PATH=E:\ipfs (no system path to E:\ipfs)
    Image below from Windows 7
  2. Copied directory contents of C:\ … .ipfs (default repo location) to directory E:\ipfs (new location)
  3. Placed install file ipfs-desktop-setup-0.7.2.exe in directory E:\ipfs
  4. Uninstalled IPFS Desktop
  5. Deleted directory C:\ … .ipfs (default repo location)
  6. Deleted directory C:\Users\ … \AppData\Roaming\IPFS Desktop
  7. Executed install file ipfs-desktop-setup-0.7.2.exe in directory E:\ipfs

repo.lock now appears in E:\ipfs indicating this as new active repo directory.
Also, 5 files updated in E:\ipfs\datastore, including file named LOCK
As further confirmation, right clicked a file to be uploaded, selected “Add to IPFS”
Files in E:\ipfs\blocks updated
In IPFS Desktop screen selected “Files” in left menu and uploaded file appears in list :slight_smile:

Appreciate your help leerspace

1 Like