# I can't open webui ,how can i recovery

**URL:** <https://discuss.ipfs.tech/t/i-cant-open-webui-how-can-i-recovery/2055>\
**Category:** Help\
**Created:** [February 10, 2018, 2:00pm UTC](https://discuss.ipfs.tech/t/i-cant-open-webui-how-can-i-recovery/2055 "2018-02-10T14:00:55Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![shishi614](https://avatars.discourse-cdn.com/v4/letter/s/35a633/32.png) [@shishi614](https://discuss.ipfs.tech/u/shishi614)\
**Post date:** [February 10, 2018, 2:00pm UTC](https://discuss.ipfs.tech/t/i-cant-open-webui-how-can-i-recovery/2055/1 "2018-02-10T14:00:55Z")

</div>

I can’t open webui.as follow:

 ![](https://us1.discourse-cdn.com/flex020/uploads/ipfs1/original/1X/8eb5f0689588ce19c635518f48c942d6b15edd46.png)  
when i Ctrl+C terminate ipfs daemon,a mistake arise.

> shihj@shihj-virtual-machine:~$ ipfs daemon  
> Initializing daemon…  
> Adjusting current ulimit to 2048…  
> Successfully raised file descriptor limit to 2048.  
> Swarm is limited to private network of peers with the swarm key  
> Swarm key fingerprint: 02f4590fa496e6626e2f62ba8992bbf2  
> Swarm listening on /ip4/127.0.0.1/tcp/4001  
> Swarm listening on /ip4/192.168.1.12/tcp/4001  
> Swarm listening on /ip6/::1/tcp/4001  
> Swarm listening on /p2p-circuit/ipfs/QmV7ZZrc76gPqSgVFsphwKWRTUzKZPs9Ewj3Ssu1d4Aftp  
> Swarm announcing /ip4/127.0.0.1/tcp/4001  
> Swarm announcing /ip4/171.214.177.154/tcp/17178  
> Swarm announcing /ip4/192.168.1.12/tcp/4001  
> Swarm announcing /ip6/::1/tcp/4001  
> API server listening on /ip4/127.0.0.1/tcp/5001  
> Gateway (readonly) server listening on /ip4/127.0.0.1/tcp/8080  
> Daemon is ready  
> 21:40:17.439 ERROR core/serve: ipfs resolve -r /ipfs/QmPhnvn747LqwPYMJmQVorMaGbMSgA7mRRoyyZYz3DoZRQ/: Failed to get block for QmPhnvn747LqwPYMJmQVorMaGbMSgA7mRRoyyZYz3DoZRQ: context canceled gateway\_handler.go:621  
> ^C  
> Received interrupt signal, shutting down…  
> (Hit ctrl-c again to force-shutdown the daemon.)  
> 21:51:26.066 ERROR core/serve: ipfs resolve -r /ipfs/QmPhnvn747LqwPYMJmQVorMaGbMSgA7mRRoyyZYz3DoZRQ/: Failed to get block for QmPhnvn747LqwPYMJmQVorMaGbMSgA7mRRoyyZYz3DoZRQ: context canceled gateway\_handler.go:621

**\> how can i recovery that mistake .I guess can,t open webui becase of that mistake ,how can i recovery???**

---

<div class="post-metadata">

**Author:** ![claudiobizzotto](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.ipfs.tech/claudiobizzotto/32/2428_2.png) [@claudiobizzotto](https://discuss.ipfs.tech/u/claudiobizzotto)\
**Post date:** [February 18, 2018, 6:18pm UTC](https://discuss.ipfs.tech/t/i-cant-open-webui-how-can-i-recovery/2055/2 "2018-02-18T18:18:35Z")

</div>

Can you restart the daemon with `ipfs daemon`?

---

<div class="post-metadata">

**Author:** ![wangshnj](https://avatars.discourse-cdn.com/v4/letter/w/d26b3c/32.png) [@wangshnj](https://discuss.ipfs.tech/u/wangshnj)\
**Post date:** [July 10, 2018, 6:59am UTC](https://discuss.ipfs.tech/t/i-cant-open-webui-how-can-i-recovery/2055/3 "2018-07-10T06:59:19Z")

</div>

I also meet the same error(context canceled gateway\_handler.go:621). have you resolved this issue now? could you please share the resolve method? thank you~

---

<div class="post-metadata">

**Author:** ![leerspace](https://avatars.discourse-cdn.com/v4/letter/l/94ad74/32.png) [@leerspace](https://discuss.ipfs.tech/u/leerspace)\
**Post date:** [July 10, 2018, 11:42pm UTC](https://discuss.ipfs.tech/t/i-cant-open-webui-how-can-i-recovery/2055/4 "2018-07-10T23:42:51Z")

</div>

Is your node connected to any peers? You can list peers using `ipfs swarm peers` to verify.

---

<div class="post-metadata">

**Author:** ![wangshnj](https://avatars.discourse-cdn.com/v4/letter/w/d26b3c/32.png) [@wangshnj](https://discuss.ipfs.tech/u/wangshnj)\
**Post date:** [July 11, 2018, 3:04am UTC](https://discuss.ipfs.tech/t/i-cant-open-webui-how-can-i-recovery/2055/5 "2018-07-11T03:04:58Z")

</div>

My node does not connected with any peers now.  
"  
Daemon is ready

wangsh@wangsh-linux:~ wangsh@wangsh-linux:~ ipfs swarm peers  
wangsh@wangsh-linux:~ wangsh@wangsh-linux:~  
"  
Do I need the public or fixed IP adress to connect with other peers?  
Now, I tested in my home network without the fixed(public) IP adress.

---

<div class="post-metadata">

**Author:** ![leerspace](https://avatars.discourse-cdn.com/v4/letter/l/94ad74/32.png) [@leerspace](https://discuss.ipfs.tech/u/leerspace)\
**Post date:** [July 11, 2018, 4:45pm UTC](https://discuss.ipfs.tech/t/i-cant-open-webui-how-can-i-recovery/2055/6 "2018-07-11T16:45:09Z")

</div>

What’s your networking setup like? Are there any firewalls that would be blocking connections to the bootstrapping nodes?

I’m having trouble finding it now, but I seem to remember coming across an issue in the past where the webui won’t load if you can’t connect to any other nodes.
