Files stored for public use, how do public find stored files

I am using a PC so the commands in the tutorials on discuss ipfs are not working
Please use a pc command line structure in your answers
or a how to, via the localhost GUI
I have stored files to my IPFS localhost for public use, not pinned
I am connected to 331 public peers

  1. How do the public find my files ?
  2. How do I find and access other peers public files?
    3 how do I communicate to ie contact the public peers
1 Like

I don’t know enough, but I always thought that ipfs (available here for many platforms including Windows) was cross-platform also in the commands that are available. (?) Anyone with more insight?

1 Like

I think that’s generally true. The only difference I can think of (or that I’ve encountered) is that a command like

ipfs config --json API.HTTPHeaders.Access-Control-Allow-Origin '["*"]'

would be the following on Windows (reference):

ipfs config --json API.HTTPHeaders.Access-Control-Allow-Origin "[\"*\"]"

Hi Jay and leerspace - tried the command ie C&P to a command prompt dos window and run it - it did not work I still get the failed IPFS Station message when trying to run via google chrome add on’s

Oh snap, it looks like your node is not running yet.

Please start it by running ipfs daemon on your terminal.

Also, please make sure you have CORS enabled, by running
ipfs config --json API.HTTPHeaders ‘{“Access-Control-Allow-Origin”: ["*"]}’

I have tried both and am stuck - daemon is running fine or I would not get a localhost and 317 peers

I still have not worked out how to communicate with the peers - but one step at a time LOL

What error do you get when running the command below?

ipfs config --json API.HTTPHeaders.Access-Control-Allow-Origin "[\"*\"]"

I just ran it again and there is no error it just goes back to the prompt > but still get the Oh snap error- will try to morrow now - off to bed 03:10 here in the UK Catch you then.

When you try again, it might be worth making sure the daemon has been restarted after running the command (if your daemon hasn’t already been restarted by tomorrow).

HI Leerspace - IPFS Station up and working, properly needed the reboot - I Just done a youtube search for tutorials none found - google just links back to here no videos - I know I am Lazy - But If someone has it all worked out for Dummies like me? why not - Thanks for help

You could try to use the Docker container , which is setting the CORS headers by default (including ["*"] as allowed origins)

1 Like