Invalid character '{' after top-level value

I’m following the instructions from “Create a local cluster
It seams that my cluster is running because I get this:

** IPFS Cluster is READY **

Then I try to do this

./ipfs-cluster-ctl peers ls

But on the command line where I launch this request I get this error:

An error occurred:
  Code: 200
  Message: invalid character '{' after top-level value

I’m on a ubuntu 20.04 workstation.
Please help me out. I’m new to IPFS.

Hello, there is a mismatch between the version of ipfs-cluster-ctl that you are using and the version that docker compose is starting.

Try to align them. The logs should say which cluster version is starting.

What logs? Where I can find the logs?
Also, how is it possible that I run different versions?

tar xvzf ipfs-cluster-ctl_v0.14.0_linux-amd64.tar.gz
# I'm guessing this is the cli 0.14.0 version

# the docker-compose.yml just states
image: ipfs/go-ipfs:latest
# how do I get access to the logs? 
# how do I see version that docker compose is starting? 

a version of ipfs-cluster-ctl should be paired with the proper version of ipfs-cluster. you have shared your ipfs version and ipfs-cluster-ctl version, but not your ipfs-cluster version.

The short answer is, if you are new to ipfs dont use cluster. manage a few nodes by hand until you know what to expect (and know where your logs are :wink: )

The same log that said ** IPFS Cluster is READY **

The docker-compose uses: image: ipfs/ipfs-cluster:latest.

Best is that you fetch the latest ipfs-cluster-ctl with:

# diding throo the logs I found this: 
ipfs-cluster-service version 1.0.0-rc3+gita2b89f9b3b384c697923b957183016b465bc200d
# so I downloaded this by adjusting your command
mkdir mkdir ipfs-cluster-ctl2
tar xvzf ipfs-cluster-ctl_v1.0.0-rc3_linux-amd64.tar.gz --directory ./ipfs-cluster-ctl2/
cd ipfs-cluster-ctl2/ipfs-cluster-ctl/
cp ../../ipfs-cluster-ctl/docker-compose.yml ./
docker compose up > my-logs.log

# on different terminal
./ipfs-cluster-ctl peers ls
12D3KooWQRBFXCDEsv1mFqUyzBnXiXwBs48E66pFfzr36zib1G4L | cluster0 | Sees 2 other peers
  > Addresses:
    - /ip4/
    - /ip4/
  > IPFS: 12D3KooWRnC96ddCjhzrQQgeFNf3zA7pg6NhsBr9g1q55H6HZjCX
    - /ip4/
# and so on and so on ........

It works. Thank you @hector
You are my hero

Thank you @hector

Digging through the logs I found this
ipfs-cluster-service version 1.0.0-rc3+gita2b89f9b3b384c697923b957183016b465bc200d

adjusting your url this is what I did:

# then unpack and docker compose up then.. (ass per instructions from my linked question)
./ipfs-cluster-ctl peers ls

And in worked.

Thank you