IPFS Desktop App for ARM

I have a spare RPi4 running Ubuntu Desktop, which I plan to set as an IPFS node. I was hoping to find the friendly IPFS Desktop app to install on it - but it seems there are only Debian packages for AMDs.

Is this indeed the case? If so, is there an ARM version in the works?

Follow up question: in case indeed there’s no Desktop App for ARM, is this tutorial to install a node up to date?

Besides, the tutorial mentions Ubuntu Server in particular. Will it work with Ubuntu Desktop instead?


Hi, IPFS Desktop ARM64 support seems to be not supported yet, but you can follow this tracking issue for future updates.

:point_right: If you want to make it work today, and are ok with not having a tray icon, and don’t mind runing some CLI commands in terminal, you can run Kubo IPFS daemon without the Electron wrapper, and get the same IPFS node as you would if you’ve run IPFS Desktop.

Here are some relevant resources:

No matter which way you’ve run Kubo, once you start ipfs daemon, you should be able to access the same WebUI you have in IPFS Desktop by opening in a regular web browser, and have Gateway on port :8080.

IPFS Companion will also work with this setup.

1 Like

Thank you very much, @lidel :pray:t4:
It’s already flying :rocket:

One additional question, if I may: must I always leave a CLI open to leave the daemon running?

I’m wondering how this goes with unattended updates, automatic reboots, and so on :face_with_monocle:

I use tmux to solve that problem.

1 Like

@ylempereur thanks for the idea :pray:t4:

You can run it as systemd service.

It really depends on your distro, but in theory if you just run:

# systemd enable ipfs
# systemd start ipfs

it should work. In practice it probably would not.

what probably will be issues is:

  • you don’t have ipfs user
  • selinux/apparmor rules might interfere with ipfs from systemd

To fix user issue you need to edit: /etc/systemd/system/ipfs.service and change user to yourself.

in case you have running selinux, easiest for you would be disable it using
# setenforce 0
you can also change default policy to permissive in /etc/selinux/config (selinux will be disabled also after reboot)

after that run a bit ipfs, try do as much services as you can
# audit2allow -i /var/log/audit/audit.log

and follow steps what that program tell you to do, this way you’ll create selinux rules for ipfs and you run it while also having selinux enabled.

In case of AppArmor, I don’t know how to work with that.

This should solve your question, if you have any question , feel free to message me.

1 Like