Ipfs enables many child processes and occupies CPU and memory resources

ipfs enables a lot of child processes, and takes up cpu and memory resources, my version is 0.4.2, it is not clear why so many system resources are occupied


You might not want to run IPFS has root. Not sure that’s a good idea for any web facing service.

This has no effect, mainly because the resource consumption is too high, how do you solve it?

I meant that from a security standpoint. It’s not secure to run any web facing service as root.

I have a handful of servers running IPFS and none act like this. I would suggest upgrading to the latest version and you look into the files they are pinning and the stats (ipfs stats) to see if you have something very popular or very large with many requests. Otherwise, turn on debugging.


Which version do you use?

Right now, 0.5.0 and ipfs-update is a handy tool to keep things current.


I have now downloaded the ipfs-update_v1.6.0_linux-amd64.tar.gz installation package to my local, I am currently 0.4 . 22. How do I upgrade to 0.5.1


For some reason, I cannot directly upgrade via ipfs-update, because I cannot directly access ipfs.io

If you’re running go-ipfs locally, you can update over IPFS.

  1. Start the IPFS daemon.
  2. Set the IPFS_DIST_PATH environment variable to /ipfs/QmZYikc1NdBaYeyxUjt7KdDRnKLWkPpDLiVgWF72dPM3jT
  3. Update.

Alternatively, you can download the latest version from github:

1 Like

update?Can it be said in more detail?

I don’t know how you managed to have so many ipfs processes (docker?) but afaik, this is not something IPFS does or can do by itself.

These processes were run by ipfs by themselves, not by me. It may be 0.4.22, but the previous version did not

These are threads not processes right? I was under the impression that Go would limit threads to the number of CPUs, but it’s true, I seem to get more than that…