Ipfs swarm connect doesn't seem to work

Hello :wave:

I was trying to connect Pinata Cloud to ls and get my own CIDs but didn’t make it work. Here is what I’ve done so far:

[WORKS] IPFS Desktop

  1. Open IPFS Desktop
  2. Click “Peers” tab
  3. Add each 6 addresses of Pinata
  4. Jump to “Files” tab
  5. Search CID: /ipfs/QmVYfNCBqrBHmgniv7NSgntafTXrh53NXSGsCziE8JuJWr
  6. Wait a few mins and you will see the files


  1. $ ipfs init
  2. $ ipfs daemon - another terminal session
  3. $ watch ipfs bitswap stat - another terminal session
  4. $ ipfs swarm connect /dnsaddr/fra1-1.hostnodes.pinata.cloud
  5. $ ipfs swarm connect /dnsaddr/fra1-2.hostnodes.pinata.cloud
  6. $ ipfs swarm connect /dnsaddr/fra1-3.hostnodes.pinata.cloud
  7. $ ipfs swarm connect /dnsaddr/nyc1-1.hostnodes.pinata.cloud
  8. $ ipfs swarm connect /dnsaddr/nyc1-2.hostnodes.pinata.cloud
  9. $ ipfs swarm connect /dnsaddr/nyc1-3.hostnodes.pinata.cloud
  10. $ ipfs ls /ipfs/QmVYfNCBqrBHmgniv7NSgntafTXrh53NXSGsCziE8JuJWr - almost waited ~10+ mins and nothing happened / bitswap stats did not change

What I’m missing here? Any thoughts? Thanks!

Doesn’t make the connection stays, if the connection was useless after 20s by default it is closed.
You should use a pinning service that supports automatic content discovery (DHT).
Or follow this guide to “peer” them: Peering with content providers | IPFS Docs

Thanks for clarifying! Just tried following command but bitswap metrics still shows zero and ls does nothing: :thinking:

$ ipfs swarm peering add /ipfs/QmWaik1eJcGHq1ybTWe7sezRfqKNcDRNkeBaLnGwQJz1Cj /ipfs/QmNfpLrQQZr5Ns9FAJKpyzgnDL2GgC6xBug1yUZozKFgu4 /ipfs/QmPo1ygpngghu5it8u4Mr3ym6SEU2Wp2wA66Z91Y1S1g29 /ipfs/QmRjLSisUCHVpFa5ELVvX3qVPfdxajxWJEHs9kN3EcxAW6 /ipfs/QmPySsdmbczdZYBpbi2oq2WMJ8ErbfxtkG8Mo192UHkfGP /ipfs/QmSarArpxemsPESa6FNkmuu9iSE1QWqPX2R3Aw6f5jq4D5
add QmWaik1eJcGHq1ybTWe7sezRfqKNcDRNkeBaLnGwQJz1Cj success
add QmNfpLrQQZr5Ns9FAJKpyzgnDL2GgC6xBug1yUZozKFgu4 success
add QmPo1ygpngghu5it8u4Mr3ym6SEU2Wp2wA66Z91Y1S1g29 success
add QmRjLSisUCHVpFa5ELVvX3qVPfdxajxWJEHs9kN3EcxAW6 success
add QmPySsdmbczdZYBpbi2oq2WMJ8ErbfxtkG8Mo192UHkfGP success
add QmSarArpxemsPESa6FNkmuu9iSE1QWqPX2R3Aw6f5jq4D5 success
$ ipfs ls /ipfs/QmVYfNCBqrBHmgniv7NSgntafTXrh53NXSGsCziE8JuJWr

Do they even host this file ?
How do you know pinata is pinning this file ?

They host this folder. We can check here: https://gateway.pinata.cloud/ipfs/QmVYfNCBqrBHmgniv7NSgntafTXrh53NXSGsCziE8JuJWr

Profile settings:
Screen Shot 2022-01-27 at 22.54.02

I can see Pin Status: Pinned info in my files page.

I face the same problem.
There is content on Machine-A - I can ipfs cat it there. It does not work on Machine-B
So I tried to connect both and did an ipfs id on Machine A - then ipfs swarm connect on the other. Still cannot ipfs cat and interestingly the other machine is also not in the list when ipfs swarm peers