Accessing Mounted Drive with IPFS

Hello Im runnin IPFS on an ubuntu server and I have a drive mounted at /mnt/torrents and when I try and run ipfs add [filename] from within any of the folders on my mounted drive I get the same permission denied error. I have already checked fstab and everywhere else to make sure permissions are correct.

Am I missing something ? Do I need to have ipfs installed and initialized on the mounted drive?
Or where can I configure IPFS to use this drive ?
ipfs add [filename]
Error: open []: permission denied

I have an 88 gb file on mnt/torrents/completed/ that I need to upload to IPFS. I can not hold the 88GB on the SD card where ipfs was initialized /home/ubuntu/snap/ipfs/ because it is to small.

Are you sure you have the permissions worked out? Can you run unzip -t 2614\ images\ from\ huble\ space\

Thank you for responding,this issue was due to the snap package confinement discussed here and has been solved… kind of. ipfs add cannot add files owned by other users · Issue #7872 · ipfs/go-ipfs · GitHub