After install - mdns lookup error

greetings! I have gotten through the install, with no apparent issue, until I go to call and check if it is working

ipfs cat /ipfs/…PeerID…/readme

it looks for a very long time, returning this:

17:15:03.903 ERROR mdns: mdns lookup error: failed to bind to any multicast udp port mdns.go:140
17:15:13.903 ERROR mdns: mdns lookup error: failed to bind to any multicast udp port mdns.go:140
17:50:52.667 ERROR mdns: mdns lookup error: failed to bind to any multicast udp port mdns.go:140
17:51:02.667 ERROR mdns: mdns lookup error: failed to bind to any multicast udp port mdns.go:140

Daemon is ready… I used the PeerID from the config file.
I’m out of ideas! Tried a few times with same results.
Any suggestions? Thanks!

updates… I added OpenDNS locations to the etc/resolv.conf , running tests like “host” show them working, for example, host ipfs.io gives me all the good replies.
now, I installed avahi. brought the daemon back, and i get the same error message above.

also, this process actually cuts out my internet briefly. once I get that mdns lookup error, message pops up that I am disconnected from the network. so I stop it, and the net comes right back on.

what next? for now I am collecting and organizing files to share!

full disclosure: I am not only new to IPFS, I am also new to running linux again after a few years. I am using the ubuntu based ‘bodhi linux’. maybe an appropriate move would be to set up a more mainstream distribution? (may be doing this anyway, for a desktop) are there recommendations for a best fit?
I would be willing to accept that as a “fix” for now while I learn the ropes.

May be related to:

great, thank you! I followed the threads… not quite seeing anything actionable from here.

You can try turning off MDNS in ipfs: ipfs config --bool 'Discovery.MDNS.Enabled' false. This will make it harder to discover other IPFS nodes on your network but should alleviate this problem.

The real solution is for us to replace our go mdns library with a better one and configure it properly.

thanks! ran that line, and see it is changed in the config file.
I am trying the “readme” test again… for now it is still waiting, waiting, hasn’t given me the error yet. hasn’t given any reply, in about half an hour.
I’ll let it keep trying…

UPDATE: this request runs and waits… no response, hours later.

What’s the output of ipfs version --all and ipfs swarm peers?

ipfs version --all

go-ipfs version: 0.4.13-
Repo version: 6
System version: amd64/linux
Golang version: go1.9.2



    dspacio@seedsound:~$ ipfs swarm peers
Error: api not running
dspacio@seedsound:~$ sudo ipfs daemon&
[1] 6930
dspacio@seedsound:~$ ipfs swarm peers
Error: api not running

[1]+  Stopped                 sudo ipfs daemon
dspacio@seedsound:~$ ipfs daemon&
[2] 6941
dspacio@seedsound:~$ Initializing daemon...
Adjusting current ulimit to 2048...
Successfully raised file descriptor limit to 2048.
Error: cannot acquire lock: Lock Create of /home/dspacio/.ipfs/repo.lock failed: open /home/dspacio/.ipfs/repo.lock: permission denied 

[2]- Exit 1 ipfs daemon

I hadn’t run the daemon at first. you can see a few tries there.
at first, I would just run, ipfs daemon& , and it would work. since changing the mdns lookup (as above) it began giving me that permission denied message.
yet yesterday sudo ipfs daemon& would work fine, give me the original reply that all went well. today it is different that the sudo command just returns that one line, ie [1] 6930 .

okay - now I try simply sudo ipfs daemon , (no & at the end), and it works again.
okay! now, I get:
> dspacio@seedsound:~$ ipfs swarm peers
> /ip4/104.131.131.82/tcp/4001/ipfs/QmaCpDMGvV2BGHeYERUEnRQAwe3N8SzbUtfsmvsqQLuvuJ
> /ip4/104.223.59.174/tcp/4001/ipfs/QmeWdgoZezpdHz1PX8Ly8AeDQahFkBNtHn6qKeNtWP1jB6
> /ip4/104.236.179.241/tcp/4001/ipfs/QmSoLPppuBtQSGwKDZT2M73ULpjvfd3aZ6ha4oFGL1KrG
> M
> /ip4/124.190.95.207/tcp/6610/ipfs/QmZ1XKpHUJjMZZNvasysLaZD7ot3RkkTW2zpHWpUJXbTgJ
> /ip4/128.199.219.111/tcp/4001/ipfs/QmSoLSafTMBsPKadTEgaXctDQVcqN88CNLHXMkTNwMKPn
> u
> /ip4/129.97.131.0/tcp/4001/ipfs/QmNyZoBmWS978DcyqwhtfgraPLk1EUJd3fC7rRhKQpKJ2J
> /ip4/13.126.171.97/tcp/4001/ipfs/Qmf8ta92aMK2xGYo5ssnFYtUvx8HCQrcpt3V3RzpmmNFto
> /ip4/134.119.186.163/tcp/4001/ipfs/QmYmEix8ox3HHpBqqrDkJbLygLcpDELJPH86whzPvT2Gj
> R
> /ip4/138.197.108.157/tcp/4001/ipfs/QmTMSgsyw3zzVbcQnkoN5SRZk7WYUMorJ7EqkqVBLgn13
> i
> /ip4/138.197.13.203/tcp/4001/ipfs/QmVJBJarrGKLRX8aaNz8g3LdEadRS9ZxefeSPG36agEhuZ
> /ip4/144.76.31.62/tcp/4001/ipfs/QmWxy2ipNU3BpsooLsnkV817p7QKjFkmxwpko3cqphkPPV
> /ip4/158.69.244.236/tcp/4001/ipfs/QmXPTviYqvRhfNpHutwxPYwPjNSXUX882bfs68Lxfq9TS1
> /ip4/159.203.60.9/tcp/4001/ipfs/Qmby67ucApS4r4JqdZ4qSYBscaYb9gnxT9uNSvcVz8vTjF
> /ip4/159.203.76.161/tcp/4001/ipfs/QmfYHS9VnhuGqweZUxJaRQ6uDjedfutsBNX11RyxNzEBkk
> /ip4/159.89.10.245/tcp/4001/ipfs/QmUZmo7puLQmofEuJ9WQR9hW8MhsTKVPLRKYgP3gMwwy5Q
> /ip4/162.244.80.159/tcp/4001/ipfs/QmaFgqvdPgE54JNVbNNe2cxy6bBFnouB83omf8kqgiETiW
> /ip4/165.227.62.58/tcp/4001/ipfs/QmUjM53zcSRhsA8BCK28DchCdSJCNmEU6W6jPJHiSgxwTW
> /ip4/167.114.233.158/tcp/4001/ipfs/QmPNhiqGg81o2Perk2i7VNvvVuuLLUMKDxMNwVauP8r5Y
> v
> /ip4/169.229.219.152/tcp/4001/ipfs/QmSUMYKijNo1UBEJseWhE2JivoRRzJT69AT5Nd5M2dByV
> Q
> /ip4/173.44.42.111/tcp/4001/ipfs/QmVbNVqy8zCyp9oG62HLnzUf8wVc4ZwNN5aY5T7FA4EhQW
> /ip4/176.112.220.31/tcp/4001/ipfs/QmNnMf3d81GBa5Cf9v4pUeYE5CspFMcttv4z8YnGMDKcgt
> /ip4/176.9.98.109/tcp/4001/ipfs/QmdhatZkb9KBupS1Hzv4cWsBrwnKEtSmBQqKphTvks91cf
> /ip4/178.134.36.66/tcp/58090/ipfs/QmTHCyXQwCMCudJkRgvrPkfVokERQRvGgK2Md7FJp7M7rG
> /ip4/178.159.111.123/tcp/4001/ipfs/QmP3ZJdTUqmRrzTGRfFkDg5wVNCeirVSXsUSC1fajnbKD
> 8
> /ip4/178.163.12.130/tcp/1034/ipfs/QmaK3yuKFYBhGu3so47x75MCsmzSe6P1wUf3W8AjbLRNRK
> /ip4/178.19.251.249/tcp/4401/ipfs/QmR2FRyigN82VJc3MFZNz79L8Hunc3XvfAxU3eA3McRPHg
> /ip4/183.87.14.128/tcp/56428/ipfs/QmRrSaZc9pe53Y4SSc6Ah9QTMJht7wroRf8kJrcSwR7czy
> /ip4/185.21.216.196/tcp/4001/ipfs/QmcWRknHParwCVoygtjGjyioUKqMoZbZwGQAY2dHSNyab1
> /ip4/185.35.202.205/tcp/4001/ipfs/QmfDQdBxcDrm5QyZWHeze25BrDepWMJd2RqAUd3bEHgEZJ
> /ip4/188.216.98.148/tcp/54196/ipfs/QmeXmJA7kU1PJstN7Qup5MmfmjDr7maWujzD5oLk9qQ7H
> j
> /ip4/188.40.114.11/tcp/4001/ipfs/QmZY7MtK8ZbG1suwrxc7xEYZ2hQLf1dAWPRHhjxC8rjq8E
> /ip4/190.156.42.73/tcp/19275/ipfs/QmcHJAEiqTmwy1VRHzdWiMbf4JUKBXCxXJAgBiQNphHtPd
> /ip4/194.1.195.61/tcp/4001/ipfs/QmeTCderRhpjwhSnPYuNA1ArY3hhac2sMxdG8JBJnLAizo
> /ip4/195.154.167.12/tcp/4001/ipfs/Qme7hrYxiHXergqQ5gaixQoHWY8JhbwsySryYDexV6nmYb
> /ip4/195.181.218.129/tcp/4001/ipfs/QmV4JnGmv1HwFrTkBMeFgERLGx7eJ7iEBbE1DdxFbYzh7
> y
> /ip4/199.116.74.154/tcp/64959/ipfs/Qmbt3ctCTnzBTdrVQS6DqtwDQpf6iMoE4QtYzPr6CRRFV
> C
> /ip4/202.83.17.200/tcp/61110/ipfs/QmTtcQGxAqhG59cb8m5AsAECXZT9Xbaueahiy8ZsHuPQ3Y
> /ip4/212.129.36.29/tcp/4001/ipfs/QmNYswasAxJaNgJwrxyVh4YQ9xKJMLo2ZEoLm9wTKrWUqF
> /ip4/213.98.22.53/tcp/28156/ipfs/QmUUje11t45XRcAy7eDkmQLxrLuPwKD9CjnUTsUmhvtThj
> /ip4/213.98.22.53/tcp/43424/ipfs/QmfM6w85aXRDsgqgTQ8h7cabcu2v55cayCmCD3Gwgbzz1U
> /ip4/219.104.77.250/tcp/24484/ipfs/QmeeJt6nbgGR7T8MH5ySFuhrSyCNkStYngvsHqrsPg6eK
> r
> /ip4/24.10.65.153/tcp/53471/ipfs/QmYjvUQpSFf9fu68Qj2fQPr7eL9cn5XBBrxCnmsDdHe3V2
> /ip4/34.192.181.130/tcp/47614/ipfs/QmanN178KJV2FpBThgwBZxxsU8WLQ195SsfH8wufYpap7
> 8
> /ip4/34.226.200.201/tcp/4001/ipfs/QmUzHWYBSjYAdgVEsEZweGK7T55KDRTrSb2BmxSyxPVV4n
> /ip4/34.237.169.29/tcp/4001/ipfs/QmYkctX9Wg5g2mBD8mnnNiCQE5toy3RqAkmzAmGEXY4dVU
> /ip4/35.204.183.83/tcp/4001/ipfs/QmdUDVBvsn3Bs1MxJ72SivZoi6a6rDSkomXZ8vWh5kPMyK
> /ip4/37.139.22.225/tcp/4001/ipfs/QmYNYMPNfm9gUARi7MQwY24zNEEeg3WP8JtESg7TgEi2bL
> /ip4/37.187.116.23/tcp/4001/ipfs/QmbqE6UfCJaXST3i65zbr649s8cJCUoP9m3UFUrXcNgeDn
> /ip4/37.47.87.95/tcp/1070/ipfs/QmNbHzbtLSxEM8H8XTwThwhZ3KWf8fWSpQp4CTBMwmkeXw
> /ip4/42.117.18.90/tcp/56354/ipfs/Qmf9LKrzdBtkttk9AUkvfnbr5LXMN6mKmTgGTxzmXEWKvp
> /ip4/45.49.247.146/tcp/22269/ipfs/QmQ8pcFD43zUsWgWDwYCFrJTVc4RHMBXPGTgbRfjjwnMRV
> /ip4/46.197.107.166/tcp/64769/ipfs/QmeDiLVPxsNv54vdw7iXQ79y1JCDSbrqyVtB2xkkZVCSY
> C
> /ip4/46.38.241.175/tcp/4001/ipfs/QmWkmnyswaY3obqdFSgAma6qkMsoStHHx6My7HLEr9Hg7b
> /ip4/47.93.45.113/tcp/4001/ipfs/QmWjniBUphMZkBp2eA3uC9Rz6P7SF17FZhjbJLpB6gXeJy
> /ip4/5.230.146.145/tcp/4001/ipfs/QmVwrDfPNPscuzxMeh5W6UNXB2Pu88PAGp2iYE2Koxa3f4
> /ip4/5.9.150.40/tcp/4737/ipfs/QmaeXrsLHWm4gbjyEUJ4NtPsF3d36mXVzY5eTBQHLdMQ19
> /ip4/51.15.168.157/tcp/4001/ipfs/QmamRwYTTV16DDzg8pkxGtLUSRRSkwMDixU6PChjCJdK1H
> /ip4/51.15.56.172/tcp/4001/ipfs/QmeUd9NtFuGgD36sbqRxiKEZKmqMXrtzUxhfMVP61cw4S5
> /ip4/51.255.82.70/tcp/4001/ipfs/QmVuzWyUDrGn6zMajKPFG2AoaPcqzCd6NifBRSFg31Dqtz
> /ip4/52.39.5.244/tcp/4001/ipfs/QmYD5GNSeoMYK73tihKNPTRKbC4NgcJAPqeNMpfZdzc87q
> /ip4/59.124.28.243/tcp/64417/ipfs/QmYQzoC3NCbVguTiFnSjnuMUfE1MMA5yjPApvxZgokz52x
> /ip4/62.210.203.249/tcp/4001/ipfs/Qmah6S95N5Y2Fy2fQufnc5DMHUmbrFtu6HmvqAM23b1nH7
> /ip4/69.116.203.142/tcp/41161/ipfs/QmYhjkYRkbwQqYTaaDBhHVy61WpaXP2NZuYQm5s4V9HVZ
> 2
> /ip4/70.45.226.72/tcp/50645/ipfs/QmcSVB3GoxjY8XRFrVeRhxsJJuhpUr1kv6EDyv42dxmZUQ
> /ip4/71.193.30.9/tcp/45550/ipfs/QmPmUEoJj1qhice1saUyNWsxtnsskkybu9fnNEuB15GX8f
> /ip4/71.198.188.115/tcp/4001/ipfs/QmTGs2NepdUcLF3wfHZQcDZPDG5XR1cQ5WdwccLVUPqmYj
> /ip4/71.61.20.181/tcp/4001/ipfs/QmTdaeXdDsn5uovczyMsMsDRdeUybszk1NWmzbJBVryBz7
> /ip4/74.207.245.239/tcp/4001/ipfs/QmUdD2QwAMq7QEiJHC48gTxbWyjfPedCJXF9AEf5m663tq
> /ip4/78.46.245.47/tcp/4001/ipfs/QmQPGra7vSsrYufaermMCNurSnt4y5iLDgfs7AG5doxLrA
> /ip4/79.67.236.26/tcp/53323/ipfs/QmQMGjDphDhD2eDtXpd92K9cdJpcJJPrCSMVjQBu3v2QW9
> /ip4/88.98.228.14/tcp/4001/ipfs/QmP9ec7jWAWGMsnoHbrcduy9zEFLiUxbo9km9pkmDNAsxX
> /ip4/89.101.91.148/tcp/4001/ipfs/Qma2KGHwrtrtM6RmTPHQ5FWu32TS4TTTL5Kjkh6r4X7kLc
> /ip4/89.74.162.100/tcp/4001/ipfs/QmXdgzkao9FFk35xiCfxT4vw542HmK28gEcbG5ZKpoixi9
> /ip4/95.165.143.226/tcp/4001/ipfs/Qmdu5TCc9irA1FxBriXNQdWj5ZvLG1qEBs7bcMgUCWzv6K
> /ip6/2001:1af8:4700:a032:1234::/tcp/4001/ipfs/QmWTiQrXvmA4N4x6KRvFcaXdDeeGkekToWBsDGbpgV6zJ2
> /ip6/2001:41d0:a:15d1::1/tcp/4701/ipfs/QmVvWyHBz86fr7oHXrcbYCnLgwd2SGDQad5WvZ3e176Ex9
> /ip6/2001:470:6f:5f::83/tcp/4001/ipfs/QmUNDo8dvTgsxPn4JeWHG2xKsaLfzv4pDPxL8DWBUXCgQ9
> /ip6/2002:67c2:6b14::67c2:6b14/tcp/4001/ipfs/QmU1idYJEx8EUEbom2LoP5N1f2a7DDFeEn15gUurfmLhDk
> /ip6/2604:a880:800:10::4a:5001/tcp/4001/ipfs/QmSoLV4Bbm51jM9C4gDYZQ9Cy3U6aXMJDAbzgu2fzaDs64
> /ip6/2a01:7e01::f03c:91ff:fe1c:364e/tcp/4001/ipfs/QmdsnZhr391NMcD3rSS2LAVRsg4goyHXawvsSFrQdg3sH9
> /ip6/2a02:c207:3001:2709:250:56ff:fe3c:5447/tcp/4001/ipfs/QmfX2Pvt6pZTfYfuUASF95k8x8Pea4AagDmjAU5qUovgJM
> /ip6/2a03:b0c0:0:1010::145e:8001/tcp/4001/ipfs/QmdxtNRkqspKXWnNZh95sfK74PuKecLrG4wNKHwcjaYEv8
> /ip6/2a03:b0c0:0:1010::7c:8001/tcp/4001/ipfs/QmNU5NgDQHMvHre3AN7VpNkVHRy3pQ6FtqnPAC432VYdcr

looks like a lot of peers!
readme request returns this:
dspacio@seedsound:~$ ipfs cat /ipfs/QmPSVjp2Ra6q5ymi6X4oxVbMaVQ7zvny83eY4UiLoUrq1r/readme Error: Post http://127.0.0.1:5001/api/v0/cat?arg=%2Fipfs%2FQmPSVjp2Ra6q5ymi6X4oxVbMaVQ7zvny83eY4UiLoUrq1r%2Freadme&encoding=json&stream-channels=true: EOF

With regards to the daemon stuff, you have to wait for it to finish starting before you can use it. The [1] 6930 line is your shell telling you that it has 1 background job and the job it just put in the background has PID 6930.

Error: cannot acquire lock: Lock Create of /home/dspacio/.ipfs/repo.lock failed: open /home/dspacio/.ipfs/repo.lock: permission denied

You’re getting this error because you have another instance of the daemon starting.

readme request returns this:

Where did you find that path for the README? It should be /ipfs/QmYwAPJzv5CZsnA625s3Xf2nemtYgPpHdWEz79ojWnPbdG/readme.

oh man - the correct line works. pardon me running us in circles!! I was confused by the line in the tutorial:

ipfs cat /ipfs/QmYwAPJzv5CZsnA625s3Xf2nemtYgPpHdWEz79ojWnPbdG/readme

Note the hash there may differ. If it does, use the one you got.

of course this seems clear now, but I was confused and put my peer ID in for the hash. again, my apology for giving us a runaround!! I got the correct reply this time, thank you much for your help!

No, this one is on us at this point. You’re not the first one to misread that. Fix:

thanks again - I was feeling foolish for a bit! seems clear now that I know, but it was simple enough to interpret the way I did. new wording could help.
I went ahead and set the discovery.mdns.enabled back to true. seems to be finding things okay.
I appreciate your help!

Ok I’m running:
$ ipfs version
ipfs version 0.4.20

$ sudo systemctl status ipfs
● ipfs.service - IPFS daemon
Loaded: loaded (/lib/systemd/system/ipfs.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2019-06-02 11:34:39 EDT; 1h 52min ago
Main PID: 964 (ipfs)
Tasks: 9
Memory: 453.8M
CPU: 7min 45.041s
CGroup: /system.slice/ipfs.service
└─964 /usr/local/bin/ipfs daemon

Jun 02 13:12:21 Livepeer-IPFS ipfs[964]: 13:12:21.871 ERROR mdns: mdns lookup error: failed to bind to any multicast udp port mdns.go:139
Jun 02 13:12:31 Livepeer-IPFS ipfs[964]: 13:12:31.871 ERROR mdns: mdns lookup error: failed to bind to any multicast udp port mdns.go:139
Jun 02 13:12:41 Livepeer-IPFS ipfs[964]: 13:12:41.872 ERROR mdns: mdns lookup error: failed to bind to any unicast udp port mdns.go:139
Jun 02 13:12:51 Livepeer-IPFS ipfs[964]: 13:12:51.871 ERROR mdns: mdns lookup error: failed to bind to any unicast udp port mdns.go:139
Jun 02 13:13:01 Livepeer-IPFS ipfs[964]: 13:13:01.871 ERROR mdns: mdns lookup error: failed to bind to any unicast udp port mdns.go:139
Jun 02 13:13:11 Livepeer-IPFS ipfs[964]: 13:13:11.871 ERROR mdns: mdns lookup error: failed to bind to any unicast udp port mdns.go:139
Jun 02 13:13:21 Livepeer-IPFS ipfs[964]: 13:13:21.872 ERROR mdns: mdns lookup error: failed to bind to any multicast udp port mdns.go:139
Jun 02 13:13:31 Livepeer-IPFS ipfs[964]: 13:13:31.871 ERROR mdns: mdns lookup error: failed to bind to any unicast udp port mdns.go:139
Jun 02 13:13:41 Livepeer-IPFS ipfs[964]: 13:13:41.871 ERROR mdns: mdns lookup error: failed to bind to any unicast udp port mdns.go:139
Jun 02 13:13:51 Livepeer-IPFS ipfs[964]: 13:13:51.871 ERROR mdns: mdns lookup error: failed to bind to any unicast udp port mdns.go:139

and

$ ipfs cat /ipfs/QmYwAPJzv5CZsnA625s3Xf2nemtYgPpHdWEz79ojWnPbdG/readme
Hello and Welcome to IPFS!

██╗██████╗ ███████╗███████╗
██║██╔══██╗██╔════╝██╔════╝
██║██████╔╝█████╗ ███████╗
██║██╔═══╝ ██╔══╝ ╚════██║
██║██║ ██║ ███████║
╚═╝╚═╝ ╚═╝ ╚══════╝

If you’re seeing this, you have successfully installed
IPFS and are now interfacing with the ipfs merkledag!


| Warning: |
| This is alpha software. Use at your own discretion! |
| Much is missing or lacking polish. There are bugs. |

Not yet secure. Read the security notes for more.

Check out some of the other files in this directory:

./about
./help
./quick-start <-- usage examples
./readme <-- this file
./security-notes

Why the MDNS errors? And how to fix?

BTW, I am running IPFS on my local LAN on a Vbox VM with bridged networking, in case that’s an issue?

Thanks,

Ray