File still accessible after I kill my ipfs daemon with no other dht providers

This might be a novice question but I have to ask

I uploaded a file using ipsf desktop app and I am able to access it via

To check where this file is hosted, I ran ipfs dht findprovs QmcXnXsnQehGFWm5wefyBiNsDLz5kVYcvehgs9NMYnCWHM
and not suprisingly , I see my own Peer ID listed ( and no others)

If I understand IPFS correctly, this means that only my node is hosting this file right now. Which means if it were to go offline, the link to this file should stop working. However, that is not happening

Even after killing the daemon, I still can access this file via its url

I have tried to check ipfs dht findprovs QmcXnXsnQehGFWm5wefyBiNsDLz5kVYcvehgs9NMYnCWHM several times and it only lists my own Peer ID

Wondering what I am missing here

The DHT is not a perfect representation, some nodes don’t publish in the DHT. also cache in an nginx reverse proxy.

Thanks for clarifying that
I was worried that I didnt kill the process properly on my machine

1 Like