I can't add large files to IPFS

I am using ipfs desktop on windows 7 and have no problem adding small files, but when I try to add a file that’s over 50mb, it hangs for a long time, then gives an error message that the file was not added. I noticed the same problem when trying to load many small files at once. I really like this platform, but if I can’t add large files, it’s quite useless.

1 Like

What is the error message saying exactly? Please paste any relevant logs.

Failed to add files to IPFS. Please try again. I have no idea where to find any logs.

Hmmmmm. Today I did a little more playing around and found that I can add large files by right clicking on them and selecting “Add to IPFS” and it works perfectly. There seems to be many bugs in the desktop program. I’ve noticed several other error messages when trying to pin or do other things to added files, even though the operations worked as they were supposed to. I just tried to drag a folder full of files into another folder, already added in the desktop and it worked just fine, but I got an error saying “Failed to rename the files, please try again”.

I also found that I was unable to use ipfs in the command line, because the ipfs.exe wasn’t added to the Systems32 folder upon installation. I found that fix by doing a search online. I added it myself, and now I can use cmd to manipulate ipfs on Windows 7.

Hopefully this is helpful to the developers. If anyone has questions about the bugs I find, please contact me and I will be glad to log and share them as I find them.


I added a file using cmd and it shows message that it was added and created a hash, but doesn’t show up in the files on the IPFS Desktop. It does however show up as a pinned item on the desktop.

IMHO ipfs.exe should not be in System32, but maybe the directory that it is in should have been added to the system-wide PATH specification? If you manually copied it to System32, then it will never get updated unless you manually copy it again.

When I add a directory tree worth of files to IPFS, I first do an ipfs add which gives me the hash and then I put that hash into an ipfs files cp to give them a name. Following that I publish the hash as my peer’s IPFS name. You can see my publish command script at:


I doubt if I will use the command line much, I’m more of a gui person myself. I just wanted to try it out to see if the problem was with the desktop application or something else. Since I found that adding files by right clicking on them worked, I concluded it must be bugs in the desktop.

The tutorial I found on how to add new PATH specs, as you also suggested, didn’t look the same as what I find with my OS, so I didn’t mess with it. I got to the environment variables, but that’s when the instructions didn’t match up with what I was seeing. https://helpdeskgeek.com/how-to/fix-not-recognized-as-an-internal-or-external-command/

Actually, now that I look at it, the PATH variable is ;\bin-win, which is where the ipfs file is located, assuming the ; is a wildcard. The file location is C:\Program Files\IPFS Desktop\resources\app.asar.unpacked\src\ipfs-on-path\scripts\bin-win For some reason, it’s not being recognized, even though it appears that it should. Changing to that location in cmd and the ipfs commands work.

Just a quick note – the large-file import issue and the error messages you mention are known issues under work right now by the GUI team. Thanks for the extra examples as we continue to troubleshoot these!

Thanks for the feedback. I’m new to IPFS, I only installed it a few days ago. I love its potential.