IPFS and X Stream Error

I posted in the stackexchange for ethereum but I was wondering if IPFS has any forum for resolving errors:

I have a lot of API access issues. I narrowed down I think the error to X Stream.

I would appreciate any help.

the /add endpoint should have a progress=false option so that it does not stream the state of the add operation. You can give it a try with that and see if your error is still there…

I tried this -
this.IpfsAPI = IpfsAPI(‘’, ‘5001’, {protocol: ‘http’, progress: ‘false’})
this.ipfsHost = new IpfsAPI({ host: ‘’, protocol: ‘http’, port: ‘5001’, ‘progress’: false });

Same result - X-Stream error.

I did some testing and it seems the data is sometimes actually being inserted into IPFS. But the system is failing to end the API call correctly. It seems what happens is the API calls enabled the data insert and then had an error (X-Stream) which caused the API call to abort and hence the processing of the API insert is not completed.

I tried ipfs.get and had similar issues. So it seems to be there is some kind of closing data block which is not being set and causes the API call to get an error code.

Hm… I’m not sure… try reporting in the js-ipfs repo (that’s what you’re using? or are you talking to go-ipfs?). I know go-ipfs API works well for this, but can’t say about js. The js devs should be able to help.

I am using ipfs-api from an import - I am unsure if that is go or not, I will try and check.