Ipfs file upload

I have a huge and urgent problem with upload file to ipfs (gateway.ipfs.io) in my javascript code.

  1. Ipfs initialize:
    const ipfs = ipfsAPI({ host: ‘gateway.ipfs.io’, protocol: ‘https’ });
    Also I`ve tried with http protocol, but have the same error/

So, when I want to add my file to ipfs, I send the POST request:
And the result is: net::ERR_NAME_NOT_RESOLVED

When I run ipfs locally, and use appropriate config, everything is good
ipfs = ipfsAPI({ host: ‘localhost’ });
My network screenshot: http://take.ms/4aAS0
I`ve install the latest available version of ipfs: 0.4.13
But current https://gateway.ipfs.io/api/v0/version is 0.14.14-dev

Also Ive tried to work with ipfs and proxy. As result Ive got 404 Not found.

I really haven`t a clue what is going on, and I will be very grateful for any help.

You have a spelling mistake in gatawey, should be gateway instead.

But also. the URL for the gateways is just https://ipfs.io/ipfs/:hash instead of htps://gateway.ipfs.io/ipfs/:hash (gateway.ipfs.io is deprecated)

Also, the public gateways are not writable, so you won’t be able to add files via the public gateways. For that, you’ll need to run a go-ipfs peer locally, or run js-ipfs in the browser and pin it elsewhere.

gatawey - it was my mistake, just typo)
Thanks a lot for your answer, it`s very useful for me!
It is a pity that the public gateways are not writable.