IPFS Cluster set up and pins files but I don't see them on peers

So I could be missing something but I think I’ve correctly set up IPFS and IPFS-Cluster in that when I run “ipfs-cluster-ctl add file.txt” it says added and I see on my other computer(the peer) that it was successfully pinned. My problem is that even though I can see the CID was pinned on the peer, I can’t see the file anywhere. I’m sorry for such a simple question but I cannot find out why it isn’t automatically replicated. My replication factors are set to 1 for min and 2 for max.
Thank you in advance :slight_smile:

See what ipfs-cluster-ctl status say about that file.

1 Like

When I run that command it returns
" > jh-VirtualBox : PINNED | 2022-02-27T15:24:46-06:00 | Attempts: 0 | Priority: false
> jh-VirtualBox : PINNED | 2022-02-27T21:24:46Z | Attempts: 0 | Priority: false
the two different machines/VMS I’m using are both named jh-virtualBox as well. Thank you for helping me out.

Here’s what the daemon posts when I add the file:

So what is the problem exactly? What do you mean you can’t see the file anywhere?

1 Like

On the second computer, the peer I didn’t run “ipfs-cluster-ctl add”, I can’t find the file I added other than seeing that it is pinned within the ipfs-cluster daemon. It is not anywhere in the local filesystem of the peer.
Am i missing something?

Yes, IPFS does not put things in your filesystem. When you add IPFS puts things on its local datastore on ~/.ipfs. Now both peers have that content in their datastores. You can ipfs get <cid> if you want to copy it out.

1 Like

Ok, awesome I thought I was going crazy. Thank you so much for all your help