'ipfs cluster' sync but 'ipfs' node is not getting values


I’m building a private ipfs cluster so that we can add a new server and it will automatically join the cluster and synch with other peers. In each server ‘ipfs cluster’ service is running and a separate ‘ipfs’ container spins up and ‘ipfs’ should keep all the pins added to the cluster from each cluster node.

I can add a new server to join the cluster without any issues and the new server added to the cluster start synching the data from the other peers as well without any issue.

But even the 'ipfs cluster service" in new server sync data from other peers(ipfs-cluster-ctl pin ls shows all the hashes in other servers), the ‘ipfs’ node in that server unable to read the data from the custer (ipfs pin ls --type=recursive command not showing pins in the ipfs-cluster in same server). But if i add new file to any of the peers in the cluster, that new added pin sync up in the new node both ‘ipfs-cluster’ and ‘ipfs’ node.
I tried to add the pin(ipfs-cluster ctl pin add QmT4CCYGCASXrCtNmTTFxt8oQbBuaynhji81iCJomoCMuC) again to push it to the new server but not synching and get an error "PIN_ERROR: context canceled " at the end.

During my search i noticed very close discussion in Sync data from an existing node to the entire cluster by @ hbarcelos and hector i tried some of the sugessions there but couldn’t resolve.

You’re ipfs node likely does not have good connectivity to the other ipfs nodes that are part of the cluster. The PIN_ERROR happens because the pin timeouts.

Since you say you are building a private network, check that the ipfs daemons are correctly configured and can bootstrap and find each others.

Thank you for looking into this.

I tried the visibility from each ipfs node and each can ping each-other and they are in same network.

But if i add new file(from any of the other nodes in the ipfs-cluster) to the cluster(after new node join) it sync with the new ipfs node without any issues. Only concern is, the files added to the cluster before new node join to the cluster are not syncing with the ipfs node in the new server but sync with ipfs-cluster.

If it shows PIN_ERROR: context cancelled, as the reason why it does not pin, it means it timed out trying to pin, and on a small network that means the ipfs node is not well connected to the rest. It’s not just pin between machines. try ipfs ping peerID instead.

1 Like

Thanks a lot. I think that was the problem. It’s routing with ‘public IP’ not the ‘private IP’.
Peer ping is failing.