IPFS Companion v3.0.0 Peers connections are always offline

IPFS Companion Chrome Extension v3.0.0
Mac OSX 12.6
Chrome Version 116.0.5845.187
After recent update to v3.0.0, IPFS companion always shown “PEER offline”, as below:

But my Internet connection is normal, IPFS host Docker container (ipfs/go-ipfs:latest) is running normally.
How to fix it?

@ssghost are you running the latest kubo docker image?
Tested docker run --rm -it --net=host ipfs/kubo:v0.22.0 with Google Chrome 117.0 and Companion v3.0.0 works fine:


If you prefer to use latest tag, try switching to ipfs/kubo:latest and make sure you run the latest version (docker pull ipfs/kubo:latest)

Hello, I tried ipfs/kubo:latest this Docker contanier and deployed it normally but the IPFS companion extension is still the same, no peers connection at all.

Currently my Internet connection is very slow, is this affected IPFS companion’s capability of detecting peers connection?

I searched the official IPFS Kubo Doc and found the “docker run” command that @lidel provided is incomplete and it did not generate a P2P port connection for the Docker container at all. The complete form of “docker run” command should be like:

docker run -d --name ipfs_host -v $ipfs_staging:/export -v $ipfs_data:/data/ipfs -p 4001:4001 -p 4001:4001/udp -p -p ipfs/kubo:latest

And by using this command I managed to restart the PEERS connection now.