IPFS gateway returns file with 10 seconds delay

Sometimes, IPFS gateway returns file with 10 seconds delay which seems to be intended.
This did not happen till 1/16, but suddenly occured since 1/17, 23:50 (GMT+9).
Our IPFS daemon is isolated from the public via using private swarm key.

I could not imagine the source of the problem.
However, since the delay is always 10 seconds (like 10 + some miliseconeds, regardless of the file size), so that I hope that this problem could be solved by changing the configuration.

I suspect one of the followings, but they don’t seem to be the origin of the source.

  1. RAID card
    I found that regular patrol read has been triggered, but this has been triggered 2 days ago and we had good service quality during the RAID maintanence operation.

  2. IPFS config
    However, I did not changed anything during last 2 weeks.
    Thus, I doubt that this might be the source of the problem.

  3. DNS
    I just found that Gateway.NoDNSLink config is configured as false on my server.
    I’m using google public DNS as primary and cloudflare DNS as secondary.
    If Gateway.NoDNSLink option is off, and something changed on the google’s DNS server, would it trigger the problem like this?

# ipfs version (official docker image)
ipfs version 0.11.0

It seems to be solved by changing the NoDNSLink option.
I also found that cloudflare DNS got problem during last few days.

I still wonder the background theories of this problem and the solution.