IPFS is causing my modem to crash and reboot

I’ve been re-directed by the fantastic team at DAppNode re an ongoing issue I have with my dappnode and IPFS causing the modem to crash at least once an hour.


  • Dappnode running since early Dec, in the last two weeks the modem has started crashing and rebooting itself only to happen again soon after.
  • I have isolated the issue to IPFS and turning it off and on will cause the issue to manifest
  • I have tried different IPFS settings; Default, Low Power and custom with lower ‘Low Water’ and ‘High Water’ values
  • I’ve had a new modem sent to me by the ISP but the issue still persists
  • The only option that doesn’t cause the modem to crash is to turn IPFS off.

Technical Set up

I have a network engineer coming this week so I was hoping that if there is a known conflict or configuration on their network that they can turn on or off I was going to request that to be enabled or disabled.

Any other advice or tests I should perform would be appreciated.

thanks all

If modem-mode means “bridge” and that device is not used for anything meaninful (the router doing all the NAT-ing etc), then it’s just probably a crappy modem. I have the same issue on a similar device. Maybe try disabling the quick listeners, or disabling the TCP listeners and see if that makes any difference. I think the devices run out of memory or something and reboot. Mine keeps rebooting until I stop IPFS. ISP-routers are the worst.

thanks for your reply Hector.

The modem has two modes; 1) Router - it is more intelligent and includes a wireless AP switch and 2) Modem - where yes, the modem is dumb and just passes traffic to the Router which does all the NAT’ing. I have it in Modem mode.
Where can I disable the quick or TCP listeners? Is this an IPFS setting or would I expect this on the modem?

these are the IPFS config options I have on the DappNode

I’m afraid you need to ask the dAppNode people. The ipfs config has Addresses.Swarm entries like */tcp/4001 and */udp/4001/quic by default.

I’m suspecting removing the quic ones may relieve the problem because I started seeing roughly when they were introduced, but that is a very wild guess.

ok great, thank you I will feed this back