IPFs some mistakes

1.webui does not display the number of nodes. The input of IPFs swarm peers on the server is to see the nodes as shown in Figure 1.

  1. upload a large point of data error, such as Figure 2 Figure 3

Thank you for your advice

This can be solved by increasing your FD limit I believe.

Could we get the rest of that stacktrace?

ncrease self-believing FD? I’m sorry I don’t understand very much. Can you explain it in detail or give me a document? Thank you very much.

*File Descriptor Limit

1 Like

Hello, thank you for your help. If I want to build multiple IPF problem nodes on a server, what should I do? You know?

When asking questions, please be as clear and explicit as possible and explain:

  1. Precisely what you are trying to do or the problem you are experiencing.
  2. Crucially, what you’ve already tried. This helps us better understand what you’re trying to do and where things may have gone wrong.

I want to build multiple ipfs nodes on a server. Can I achieve this? How to do it?

You can set the IPFS_PATH environment variable to specify a different repo for each IPFS node. You’ll have to make sure to configure them to run on different ports. Take a look at the Addresses.API and Addresses.Swarm settings in the config. You’ll also probably want to disable the gateway (set the Addresses.Gateway setting to “”).

After exporting IPFS_PATH=/ipfs, then create ipfs init node? This will not lead to the node I created before the failure, or need to configure the port in the file and then modify the environment variables, and then ipfs init to create a node. Environment variables can be specified to modify a node? If used directly
Export IPFS_PATH=/ipfs will not modify the environment of all ipfs nodes. Do you have a reference link to the relevant document and send it to me for reference? Thank you!

thank you very much!

oh,this answer does not solve the multi-open ipfs node problem. I have run two daemons at the same time, but I can only access one via webui. I have no other solution!

How are you accessing the webui? That is, what URLs are you using?