Links to preview files don't work in webui?

I am running IPFS in a Docker container on a separate computer within my home network, and in setting the CORS headers settings to use the host computer’s local IP address of “” and API configurations to use “” (, I can get “” to resolve properly from another computer on the network, but if I navigate into the “Files” section, and click on a JPEG that’s saved there, the UI shows a broken image because it’s trying to load “…”. So it appears to be using the wrong IP address to try and fetch the image.

How can I configure this instance to not use “” (the “use all IPs” config option), and not “localhost” but use “”, the IP of the Docker host machine? If I put “/ip4/”, as the “API” config setting, then the webui doesn’t work at all (appears to be failing since “” is not an IP address that the Docker Container can see?).