New to IPFS, want to confirm some expectation's

Hello, as the title says, I’m somewhat new to IPFS in general. I have a high-level overview and I’ve done some experimenting with kubo and the IPFS companion, which didn’t always turn out as expected, so I’d like to confirm if I’ve gotten a wrong impression about IPFS or have misconfigured something.

For my first experiment, I’ve tried to create a small html file, published it from desktop pc and was able to access it from my phone over IPFS without trouble:+1:
Then I tried to step it up a video file (81MB) that I’ve imported via the companion. Watching the video over ipfs worked flawlessly on the same desktop, but very slow on my phone.
Looking at the throughput on the companion, I was able to see that the output of my node rarely exceeded 150 KB/s, which made me wonder a bit:
I started the node recently after updating the from an older version of the client and I’ve never touched the configuration, but I’ve tried to apply the profile “flatfs” via CLI, which didn’t change anything in terms of throughput, so
I’m unsure about what could be the reason for this.

  • Is it a realistic use-case to use IPFS to stream videos?
  • Is this a weakness of the routing protocol when there is only one other seeder? (Also, is seeder the correct term here?)
  • Could this be a bug on my system or network configuration?

Thank you in advance

1 Like

@Awlexus did the video file were loading correctly ?

AFAIT you are adding and “downloading” the file from the SAME node.
If that correct, what really happen is just that the add copies the video file’s blocks into the .ipfs/blocks folder.
And when you try to stream it, Kubo realise a local copy already exists and just read it from .ipfs/blocks.

Hi, thanks for the reply and sorry for being slow to answer. Yes, the video was partially loaded without errors, but it took tens of minutes to load 30 seconds (only a third of the file), so I gave up on it.

Thanks for explaining how to lookup works if the file is already saved locally, but I’d be more interested to know why it wasn’t possible to watch the video I host from another device in a reasonable time span. I can exclude my connection speed, so I assume it’s either a miss configuration or a misunderstanding of the protocol.

Without investigating I don’t really know what is the issue here.

Most of the time it’s NAT reachability issue, where you node is hidden behind a restrictive NAT.