Pinned files dissapered. Can the node unpin some files for some reason?

Hey. We have a node and uploaded 600 files to it. We published them with the IPNS name. It was working fine for some time, but several weeks later we found that most of the files were unavailable. Some were still reachable.
We then checked this IPNS name with Public Gateway Cacher, many gateways were able to cache successfully, but despite this most files were still unavailable.
I have tried to check availability with ipfs dht findprovs and the missing files were not found anywhere.
So the question is - how could that happen?

Can the node unpin some files for some reason?


If you do ipfs pin ls you should see all your pins. If the question is “is my data in my node?” then check your node for the data, don’t rely on gateways for that as there’s too many variables.

Weird, but my node seems to get stuck when I do ipfs pin ls. It’s been 12h since I started that command and still no output, nothing.
I just tried to do ipfs pin ls --type=all --stream and it returned 64 hashes and then seems to get stuck again.

Is it possible there’s an issue with the storage medium? That’s very strange.

Edit: systemctl --user status ipfs might have more logs (assuming you’re on a Linux machine)