Pinning does not happen concurrently but in sequence

From @matthiasbeyer on Sat Apr 08 2017 14:36:58 GMT+0000 (UTC)

(Pasting this here because I’m not sure whether it belongs to)

Version information:

go-ipfs version: 0.4.8-
Repo version: 5
System version: amd64/linux
Golang version: go1.8


Bug, unexpected behaviour




If I run cat hashes | while read h; do ipfs pin add "$h" & done or ipfs pin add (so it reads from stdin) and paste a list of hashes into stdin, it seems to try these hashes in sequence rather than concurrently (what would be the expected behaviour).

Because of this I failed to pin ~25 hashes for the last 3 days. Just because the very first hash couldn’t be fetched. All others seem to work now…

Copied from original issue:

From @Kubuxu on Sat Apr 08 2017 21:42:03 GMT+0000 (UTC)

< hashes | ipfs pin add - might work better.

ipfs pin add works in serial as for pin lock.

@lgierth can we resolve it somehow? We don’t need to hold pin lock while fetching.

From @lgierth on Sat Apr 08 2017 21:58:31 GMT+0000 (UTC)

Workaround for now is a round of ipfs refs -r <hash> (which works concurrently too) and then the pin round.

was this issue ever resolved? I ran into this issue where if I was trying to pin content to IPFS, I’m unable to upload files or pin other content