Question: Repetitive, probably - I cannot start IPFS desktop (Directory Missing Sharding File)

Hi. I have searched for this question because it seems like it would be common. Here is the issue: I can install the IPFS-companion (Brave Browser), but when installing the IPFS-desktop (Windows 10 Pro), this desktop program will not run. It will try and run, but then errors at sharding file missing. I checked the error log and all seems well, except this entry:

Begin Log entry>>
1 2020-09-03T02:25:43.413Z error: [ipfsd] start daemon Error: Initializing daemon…
2 go-ipfs version: 0.6.0
3 Repo version: 10
4 System version: amd64/windows
5 Golang version: go1.14.4
7 Error: directory missing SHARDING file: C:\Users\jtodd.ipfs\blocks
9 Command failed with exit code 1: C:\Program Files\IPFS
10 Desktop\resources\app.asar.unpacked\node_modules\go-ipfs-dep\go-ipfs\ipfs.exe daemon
11 --migrate --enable-gc --routing dhtclient
12 Error: directory missing SHARDING file: C:\Users\jtodd.ipfs\blocks
13 Initializing daemon…
14 go-ipfs version: 0.6.0
15 Repo version: 10
16 System version: amd64/windows
17 Golang version: go1.14.4
19 at makeError (C:\Program Files\IPFS Desktop\resources\app.asar\node_modules\ipfsd-
20 ctl\node_modules\execa\lib\error.js:58:11)
21 at handlePromise (C:\Program Files\IPFS Desktop\resources\app.asar\node_modules\ipfsd-
22 ctl\node_modules\execa\index.js:114:26)
<<End Log entry<<

Any help on the error (line 12 and 7): directory missing SHARDING file: C:\Users\jtodd.ipfs\blocks ??

What I am using or have tried:
Windows 10 Pro 64bit
updated node.js, go, npm

Tried to install by downloading the file from GitHub, the same error occurs.
Tried to install by using choco install…, the same error occurs.

Any suggestions or comments are welcome. Thank you.

  • Bull sends.

Can you try copying the ipfs directory to somewhere else, and then reinstalling ipfs-desktop?


Thank you. I deleted both directories, .ipfs and .ipfs-desktop, and then uninstalled the ipfs-desktop. After, I reinstalled and it worked. I appreciate the help.
Take care,
Bull sends.

1 Like

how did you delete the .ipfs directory? I’m having a hard time locating it. I have the same issue. I’m using mac M1. :disappointed: