I cannot browse my files from the IPFS app

I’ve tried restarting the node and app multiple times

1 Like

I just removed my ipfs folders in ~/ and it worked again (But with all my files gone)

1 Like

Bit unfortunate that you did not keep a copy of ~/.ipfs – there is a high chance we would be able to debug and recover your data.

Do you remember if you imported anything to your Files via Import → From IPFS
or did anything in command line that involved ipfs files cp ?

Recovering my data wasn’t an issue since I still had a local copy of everything I added, and no, I didn’t import anything that way (Unless using the companion browser extension counts).

Ack. If anyone is able to reproduce this, please fill issue in GitHub - ipfs/ipfs-webui: A frontend for an IPFS node. and either attach “problematic” repo to bug report, or share it with me privately.

I’m having this issue due to ipfs-js not sharing the same repo/config/etc. Uploading programmatically fundamentally uploads to a different location.

Additionally, running the ipfs desktop means that it places a lock on it and it can’t be shared with ipfs-js while it’s running. Is there any way to solve for this?

You can use RPC API to talk to an existing daemon. Usually, when folks want to run only one thing, they run ipfs-desktop/go-ipfs and talk to it from CLI or JS RPC Client:

  • CLI: ipfs --api /ip4/
  • programmatically in JS with js-ipfs-http-client:
    import { create } from 'ipfs-http-client'
    const client = create(new URL(''))
    const { cid } = await client.add('Hello world!')
1 Like