Some questions from a new IPFS user

Hello everybody.

These are my very first experiences with IPFS. I have some questions:

  1. In IPFS, is there a way to check if a peer is safe / trusted?

  2. Is IPFS Gateway nothing more than a node exposed on the internet?

  3. When I start a new node / gateway do I have the possibility to limit the peers contacted? Could I leave only the official Protocol Labs active?

  4. I install my nodes on Ubuntu. Does the installed version of IPFS update automatically or do I have to update it manually?

  5. If I wanted to tell IPFS to load (in addition to the default ones) also all my corporate nodes where should I add the identities of my nodes?

  6. Is there a reputation level of peers?

Thank you.

I don’t understand the question.

IPFS data exchange is trustless. CIDs include cryptographic hashes of data, so you are able to verify the perfect integrity of the data by using thoses hashes.

It could, but that wont scale well, ipfs.io has a geobased loadbalancer for example.

Try ipfs config profile apply lowpower

No, you wouldn’t have access to the network if you did that.

Manually, we have a tool to make that a one command action: IPFS updater | IPFS Docs

I don’t understand what you want, IPFS use a DHT for routing content, as long as they are both online and connected to the network they can find each other and exchange content.

If you want to skip the DHT and keep a connection open 24/7 you can use the peering config or use ipfs-cluster (which setup peering for you as well as having much more features like pinset replication, …).

No.

2 Likes

Thanks!

One more question, can I change the node archive path? I want to assign an ISCSI drive that is on a NAS, instead of the default disk.

Thanks again.

You can control that with the IPFS_PATH environment variable.
You can also just use a symlink wherever it’s currently at.

2 Likes

Thanks, I solved with your advice, I write what I did so maybe it can be useful to other “new” ones in the IPFS world:

edited /etc/environment and added the path to the bottom of the file

rob @ IPFS-2: ~ $ sudo editor /etc/environment
IPFS_PATH = "/mnt/raid/ipfs"

After the above change when starting IPFS I got a partition access error. I solved it like this:

change permissions to the raid partition
rob @ IPFS-2: ~ $ sudo chown rob:root /media/raid

rob @ IPFS-2: ~ $ ipfs init

… generating ED25519 keypair … done
peer identity:
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
initializing IPFS node at / media / raid / ipfs …

It works perfectly. Thank you.

IPFS works, but after changing the path the update script comes out with an error:

~$ ipfs-update install latest

Error fetching: open /media/raid/ipfs/api: no such file or directory
Fetching with HTTP: "https://ipfs.io/ipns/dist.ipfs.io/go-ipfs/versions"
Already have version v0.14.0 installed, skipping.

Some idea?

I think it’s trying to access your running daemon, but it seems IPFS is down.