~300 kb file size limit

I just pinned several files at Pinata and I’m trying to download them with fully connected ipfs peer 0.9rc1. It seems that I just cannot download file bigger than about 300 kilobytes, I doubt it has something to do with the message I get in daemon: “2021/05/24 21:27:26 failed to sufficiently increase receive buffer size (was: 208 kiB, wanted: 2048 kiB, got: 416 kiB). See UDP Receive Buffer Size · lucas-clemente/quic-go Wiki · GitHub for details.”

Anyone experiencing the same, is it some bug or what?

I was right, it’s not related to it… I increased UDP buffer size, I still can’t download anything bigger than 256 kb

How are you adding the files? How are you downloading the files?

I dragged and dropped files to Pinata, and used ipfs get on my local daemon to fetch them. On a machine which is connectable from the Internet, I cannot download files larger than ~300 kb, and on a machine that is not connectable it says “Error: failed to fetch all nodes” for every file I try to download, but for example ipfs ls QmT4DTFqr7aUjPAwARygDHTq1PAaEUaLAX1DExXJw93MsG works. That is my actual directory on ipfs, so you can try out…


Matt from Pinata here.

Would you be able to try downgrading to IPFS 8.0 and see if things are working for you correctly? From all of our tests, we’re able to download your content using nodes running 0.8.0. I would like to verify this isn’t an ipfs version issue.

1 Like

I also just tested this with an 0.9.0 repo and things worked fine. Do you have any special configurations on your node / is there any chance you would be able test with a fresh repo?

1 Like

0.8 was giving me some weird startup error which was solved with 0.9 … but I may try again… Nothing special on my node, all the settings are default. I can test it with whatever you tell me to test it with, supply me with some CID, I can try again

I just restarted clients and I can download everything now. Still… this was definitely some bug.