Trying to download from IPFS to Computer using "Ipfs Get". Pls help

Ive downloaded and am using the IPFS CLI Terminal on my Mac. Ive initialized and set up the daemon. It is running.

Then in a new window i ran the command
ipfs get QmYxZ1nd2v8vndskhsVUPx3kEVEpe28gM1nHTQD692tXp9

This is a CID to my folder with 70 GB. Its a large file. However the terminal only ever allows me to download a max of 250MB After that it stays stuck. The Percentage never increases and the time slowly counts down to 0. The weird part is i tried downloading with IPFS desktop instead and same result. I get a download package on 250MB.

On the “Files” tab of IPFS desktop I see that “Total Blocks” is also 250MB. So something is happening that is preventing me to download more than 250MB.

Will upload pictures in post and replies:

Here showing IPFS Desktop, “All Blocks” is 250MB

This showing the CLI Terminal. The download gets stuck at 250MB and never progresses any more…

Here i tried downloading through IPFS desktop, and i get a file size of 250MB

What seems likely is the first 250MB are highly available, but the rest isn’t. It’s possible your node simply can’t find the other 65.5GB. That said, I seem to be able to poke around that collection just fine so I’m not sure.

If I had to guess it’s trying to download everything in a specific order, and not able to find certain blocks. For example I can poke around in the collection just fine, but if I run ipfs get on it, I only get the first 20MiB.

Would you know how I can fix this? I really need to download these 65GB… Or maybe any other ideas?

Do you know where the data is hosted? You could try contacting the provider.

Its on Pinata, what should I tell them? Just explain the issue like i have here?

1 Like

Yeah exactly, tell them your CID, that you’ve tried to download it using IPFS directly, and try to get their advice on how to best do that. I’m sure they’ll be happy to help out :slight_smile:.

1 Like

Super weird too because if i try to get a specific file with

ipfs get QmYxZ1nd2v8vndskhsVUPx3kEVEpe28gM1nHTQD692tXp9/1000.jpg

It hangs on the CLI Terminal and nothing happens. I can even tell where the cut-off happens.

In the file

It downloaded the files one by one starting from the top. (I have on my computer) all the files up til 4395.jpg. (have to scroll down a bit on the file to see it)

After that nothing downloads, even if i try to download it individually. Super weird.

Anyways i sent them a message… hopefully we can solve

1 Like

Please keep us posted here too, I definitely want you to get all your data back :slight_smile:.

Hey! I managed to solve it and now downloading :smiley: Thanks for the help!