Corrupted Download? Stuck at 916mb

So there isn’t a warning anywhere that shows me a hard limit on file sizes. If there is some unknown file size limit, why isn’t it posted anywhere? Me and my girlfriend were trying to send files to each other. Because FTP requires port forwarding and is a pain in the ***. Cloud storage honestly sucks. So this seemed to be the best call. Since IPFS seems to be the only method that doesn’t seem like a massive gaping security hole that’s hard to configure.

Unfortunately, while it is working for other files. It can’t seem to be able to download past 916mb. Once it does, the program breaks. I tried downloading from Firefox and Chrome. And tried using the ipfs get terminal command.

The ipfs hash I was using is this. “QmWm6WiUrp9rD9N1s9z4G3h4X7gjUrM7ch7qZC8wA1jxcP”

How are you downloading the file? Using a public IPFS Gateway?

Ideally the IPFS gateway should download from your node all the 4.7GB to be able to provide it back to you… meaning that you have to upload to one or more nodes that size. Probably for this case an IPFS gateway is not the best solution as the content is not available from the gateway itself.

As you are doing correctly, use the CLI/local node to retrieve the file. From a terminal you can run

$ ipfs get QmWm6WiUrp9rD9N1s9z4G3h4X7gjUrM7ch7qZC8wA1jxcP

Remember that somebody should be distributing the file to be able to retrieve it! Even if few people have multiple pieces of the file, you should be able to retrieve it… the best way is to keep the node that you used to upload up and running and connected to the network. This may take time as the connection/speeds of the nodes may vary.

I did try to use ipfs get before. Not sure what you mean by IPFS Gateway, I just turned on IPFS like normal and attempted to download the file. I might tell her to reupload the file and see if it’ll work.

The file is not “uploaded”, instead it is added to your local node (by using ipfs add). Then its pieces are sent only to the other nodes that are requesting it. If you try to download it via a gateway (a bridge between HTTP and IPFS, ex$CID,$CID or$CID) then her computer will upload it to the IPFS Node of the gateway.

If you do ipfs get it will be “uploaded” to your local node, as you will request the pieces. So technically she is sending/uploading it directly to the nodes that are requesting it… only by demand. If pieces of the files are already cached in other nodes, you will be getting those from them. That is why it may get stuck to ~900mb, because she was able to upload only those pieces to other nodes.

If I try to get the CID you shared (hash) via ipfs get I can only get ~200mb, because all the other pieces are “missing”, since no other device is caching them is connected (aka, your gf node). Try to ask her to:

  1. Keep her IPFS node alive and connected to the network
  2. Request the file to some public gateways (find some more here: )

:slight_smile: I hope this is helping ; Plz anybody; correct me if I am wrong/missing details