Content was not loading, now its loading

Hi There,

On Friday 24th Dec, we were not able to load content from IPFS
There was more files had same issue like this.

Same files started loading from yesterday automatically. We didn’t did anything to make it working. We tried accessing these files from multiple region like USA, Asia etc

what could be possible problem?

Thank you

We don’t know, if you share the CID I might check.

Thank you @Jorropo for quick response.
here is CID QmYymZqpzZfTHPrdZCAGWU95KuXHNSZ5dGPwuUQqskJULy

Thank you

So I’ve run:

$ ipfs dht findprovs QmYymZqpzZfTHPrdZCAGWU95KuXHNSZ5dGPwuUQqskJULy

And there are not nodes returned.
So this mean that nodes hosting that file doesn’t advertise on the DHT.

You can only download that file if you happen to bump into the hosting node by luck in the sea of 11k public nodes of the IPFS network.

If I run that:

$ vole bitswap check QmYymZqpzZfTHPrdZCAGWU95KuXHNSZ5dGPwuUQqskJULy /dnsaddr/ | jq .
  "Found": false,
  "Responded": true,
  "Error": null

So I’ve basically just asked pinata’s node “do you have that file ?” and they respond with yes.


This file is hosted by pinata, pinata doesn’t use the DHT (note the DHT is a mesh of nodes that allows to find where content is).
You can use a pinning service that use the DHT instead like, or

Maybe see this: Peering with content providers | IPFS Docs also

1 Like

Thank you @Jorropo for details. this give us good direction to find root cause of issue.

1 Like