Desktop and daemon

Hello, I’m trying to use IPFS desktop. I followed the instructions but got a “could not connect to the ipfs api” message on the app (image 1). I also run “ipfs deamon” and it says that the “address is already in use” on my terminal.

I’m using an iMac M1-based.

Thank for your help!

Did you exhaust each of those 3 suggested points in your debug/troubleshooting?
If you did it would be helpful to show the results of that so others may have a sense of what is going on. As it is you have made a very vague post and it that is why nobody has replied.
Please post what you’ve done so far that has failed and I can help you.
You are using a Mac which I am only familiar with the Unix aspects of the OS X.
When you ran the daemon did you do that from command line or ?
It could need to be restarted. That would explain why it says that the address is in use already. Or it could be because IPFS desktop is using it … see the issue with no documentation or screencaptures ? Can’t eliminate possible sources of error and have to trust that you did a proper remedial action.
Another possible source of duplication that I have observed on my own PCs is the installation of Brave browser, especially beta version. It creates an IPFS node (IPFS/IPNS gateway) in its application path.
I believe that there can only be :point_up: IPFS daemon/desktop/gateway/node per machine. Or physical network interface (NIC).
A multihash is created of HWID or NIC and that is your machine’s “Peer ID”.
This is a Unique ID and therefore there should only be :point_up:… I run a Dell Poweredge server that has two dual GbE NICs (a Broadcom and an Intel). I installed both IPFS Desktop and Brave Beta browser as well as Kubo (Go-IPFS), IPFS cluster CLI and IPFS Daemon.
Therefore I have a .IPFS directory on the disk AND a /UserProfile/AppData/Local/Brave/IPFS
Path but still the same :point_up: Peer ID that references it.

  1. Yes I exhausted each of those 3 suggested points, but see point 3.

  2. I did run the daemon from the command line. I restarted my computer.

  3. But I think you identified the problem. I do have Brave browser installed. When I run “ipfs id” on my terminal, I have an ID, PublicKey, kubo/0.14.0, ipfs/0.1.0…

  4. I have not installed ipfs cluster CLI, should I?

  5. I have a .ipfs hidden directory (/userprofile/.ipfs)

  6. I also have a unix executable file located: /userprofile/.local/bin/ipfs

  7. But can’t find any IPFS file in: /userprofile/Library/ApplicationSupport/BraveSoftware/Brave-Browser/

Should I move a folder? Uninstall Brave? Execute this command
“export IPFS_PATH=/path/to/ipfsrepo”?

Thank you so much for your help!

I suggest that you uninstall Brave browser to eliminate the conflict it has a hidden IPFS node within its installation. I don’t know what is analogous in Mac file system as I use Linux and Windows. But remove the conflict before anything else is installed. After Brave is removed cleanly you won’t have a conflict. I would only install cluster-CLI if you plan to span your IPFS nodes across multiple machines on different networks. I found that I had major difficulties trying to run multiple nodes from my residential IP. I even introduced a VLAN switch which helped but I was still working against myself. So what I did was go back to my original setup which was a private network of 3 nodes bootstrapped with one another.

Thank you! I will try this out.