Sites in browser fails after starting IPFS-desktop 0.23.0 and 0.24.0 in MacOS

After installing (IPFS-Desktop-0.23.0.dmg and 0.24.0) and enabling it, from instantly to after a few minutes, some sites/web-pages won’t respond properly in the web browser Firefox (with Adblock Plus, Ghostery, NoScript, uMatrix) at the same time Google Chrome (with uMatrix) fails the same sites - e.g.:

https://downdetector.com/
https://docs.sophos.com/esg/sixm-android/help/en-us/index.html

System: Updated MacOS 10.15.7 (19H2026). Hardware: MacBook Pro (15-inch, Mid 2012), 2,3 GHz Quad-Core Intel Core i7. RAM: 8 GB 1600 MHz DDR3. Installed Sophos Home Premium.

(I have also tried to restart the PC after installing IPFS-desktop - same problem)

When web-access failed the dns-reply was ok:
$ nslookup ipfs-search.com
Server: 10.xx.0.1
Address: 10.xx.0.1#53
Non-authoritative answer:
Name: ipfs-search.com
Address: 146.70.80.218
$

$ nslookup downdetector.com
Server: 10.xx.0.1
Address: 10.xx.0.1#53
Non-authoritative answer:
Name: downdetector.com
Address: 104.18.1.148
Name: downdetector.com
Address: 104.18.0.148
$

Ping was also ok while failed web-access:

$ ping ipfs-search.com
PING ipfs-search.com (146.70.80.218): 56 data bytes
64 bytes from 146.70.80.218: icmp_seq=0 ttl=55 time=17.408 ms
64 bytes from 146.70.80.218: icmp_seq=1 ttl=55 time=11.200 ms
^C
ipfs-search.com ping statistics —
2 packets transmitted, 2 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 11.200/14.304/17.408/3.104 ms
$ ping downdetector.com
PING downdetector.com (104.18.1.148): 56 data bytes
64 bytes from 104.18.1.148: icmp_seq=0 ttl=57 time=12.277 ms
64 bytes from 104.18.1.148: icmp_seq=1 ttl=57 time=11.097 ms
^C
downdetector.com ping statistics —
2 packets transmitted, 2 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 11.097/11.687/12.277/0.590 ms
$

Se attachments.

Firefox:

This sounds like a router issue: Writeup of router kill issue · Issue #3320 · ipfs/kubo · GitHub

I use a Fritz!box router - and another PC simultaneously works fine, so that should not be the problem according to “Writeup of router kill issue #3320”.

Please note that ping and dns works fine simultaneously on the same PC.

Please note that when I shut down IPFS-Desktop or turn it off, all sites instantly works in the browsers after reload of webpages. (tried more than 50 times)

I have now activated the IPFS-desktop, when behind a firewall that logs everything. When the browser sites fail, no firewall session limits are hitted at all !

The firewall in question can handle 100000+ sessions.

Something is wrong with IPFS-desktop.

I have also tried to install the plug-in IPFS companion in Firefox - no help/change.

I also tried Apple Safari (no plug-ins) - sites also fails in this browser.

I have also tried to disable the MacOS firewall - web-access still fails.

Please help so I (and many other Mac users?) can participate with IPFS :slight_smile:

Sorry I have no idea what your issue is, but I can try to point others to this issue.

FWIW I, and many others use MacOS with IPFS Desktop without issues. It’s very strange to me that you’re having that issue.

I have now found out that the reason is Sophos Home Premium.