Share link does not work in IPFS Desktop


I’m trying to get familiar with IPFS and found the tutorial to Host a single-page website on IPFS.

I’m working on Ubuntu 20.04 and the installation of IPFS Desktop was easy from the Ubuntu Software store.

I can see the some activity int he Status or Peers pages, all seem to be working. If I create in my laptop the suggested index.html (the very same), I can get the link and paste it into a browser and get the page as expected.

But if I change anything in that index.html or try to upload any other file (txt, mp3, pdf, xml) that would not work either.

I have the feeling that the first index.html is available somewhere in IPFS already and I’m not actually looking at my copy of it. For anything else I try to add, it’s just not working.

I have seen similar behavior deploying IPFS via Docker, but would like to focus on fixing this first, then go back to that option.

I’m working from home and have enabled UPnP in the ISP router, to which I’m plugged via ethernet cable.

I’m including the header of my config file, I hope you can comment on it.

Thanks in advance.


Follow-up to original post, the Config.


My current advanced config, hiding in blue my confirmed public IP:

What kind of link do you use? Is it CID, the CID of the freshly uploaded directory should be used instead of the old one. If the site is published over DNSlink or IPNS key, do you use ipfs name publish command before trying to access the new version?

Any data published in the IPFS network will be accessible from anywhere by CID, so it does not matter which node you use to access the site if your current publishing node accesses the whole network. Do you have any peers in the swarm?

Hi @twdragon,

I’m using the links I get from “Share link” option in the three dots to the right of each file in the IPFS Desktop Files section:



These files are brand new (no updates). I can see peers in my network all the time.

From the three dots menu in Files, I can “Explore” the files and there I find some more information and two links, “View on Local Gateway” and “View on Public Gateway”:

The link for the local gateway works. The link to the public gateway doesn’t.

Local: http://bafybeihah2evb3ako3npqf3xdvjsuwutwho6s4cl42immzxhpdzp2wcbsm.ipfs.localhost:8080/

Public: Boostagram Ball

@vegfvegf I tried to access your link

Local: http://bafybeihah2evb3ako3npqf3xdvjsuwutwho6s4cl42immzxhpdzp2wcbsm.ipfs.localhost:8080/

using my gateway, and the XML file is accessible over the link:

So, the data are propagated successfully over the network.

Also, I tried to convert the CID QmXp1jP63UJZhfTkxYuMyJ8773CdE2s6zJF5jmSuM4is1U to CIDv1 manually:


and the link
easily provides the image, so everything seems normal. I guess, the addresses of your blocks are not propagated fastly over the public gateways. What error do you receive in responses from the public gateways?

1 Like

Hi @twdragon ,

I have tried the links you shared and they work well too.

A few days ago I consistently got error 504 when I tried the links from the “Share”. Now I just get “The site can’t be reached”.

I appreciate the help yo have provided. I will now investigate how to run my gateway, I guess that’s my next step.

Thanks a lot.


Can you try, it could be that your node is behind DHT operations this will tell you how to fix this (you can turn on accelerated dht client in the config to fix that) ?

Thanks @Jorropo , all the checks there are correct there:

I see your Kubo version is outdated, updating would give you more stable muxers.
Else it should work so could be an issue with the gateway.

@Jorropo ,

My Kubo was installed with IPFS Desktop, freshly downloaded. Yes, I will investigate the Gateway as recommended before.