Files not available

Hi, I’m at a complete loss. I’m new to using IPFS and I’ve just tried a few basic things. I’ve used the CLI, run ipfs init, then ipfs daemon. With it running, I’ve added a file using ipfs add <fileline>, and received the hash.

Now I cannot for the life of me access it remotely. I first tried to add the CID to Pinata, but after 2 days, the file has still not been found. Next, I opened the web gui via the link given when you run ipfs daemon. The files don’t show up but I can see the file size of the .ipfs folder go up when I add files via the command line.

Next, I used the web gui to add a file. This worked. I can access it by changing from my local address, to and this file displays. However, none of the files I add via command line will display.

Any suggestions on what I’m doing wrong? I’ve looked around and found a few people post with this issue, but their solutions don’t work or lead to now broken links.

CID of uploaded via CLI: Qme33z62veDYcartcWnk5VKtwmShamkAa9buwCcaZe4gYX
CID of file uploaded via web interface: QmVGNAP4U7fRxGz3pfoJnN4qzsRm9FVs2YT2WWdPVgtHiY

I’ve also run ipfs id and confirmed it seems to be connected. I have also used ipfs cat <file> to pull down a file successfully.

Any guidance would be helpful. I’ve been stuck on this for days!

Just to be sure, your own node was running for 2 days but Pinata did not found the CID?
Make sure it’s accessible from the internet. I don’t think ipfs id would tell you that.

If you use the explore tab in webui can you see your file/folder?
If yes, your file was added but will not show up in MFS.

MFS is separate, files will not show up when added with ipfs add

Thanks for your reply, SionoiS.

That’s correct, I kept my node running and Pinata didn’t find the CID when using ipfs add <filename>. The file I uploaded via the local web interface was found by Pinata, however. I was under the assumption that adding a file via the web gui was akin to saying ipfs add.

In my explorer tab, I cannot see the file I added via the CLI. I can import it using the hash, however it doesn’t display the image. Eg I can view it locally, but when I use a sharable link, the file won’t load:

If my goal is to add an image via the CLI and have it found by pinata and accessible on other nodes, is there something further I should be doing? Or is this an error I’ve introduced possibly in my setup?

Did you pin the file added via CLI? Maybe it was GCed, I think files in MFS are “pinned” by default.

I would do a ipfs repo gc then ipfs add --cid-version=1 <YourFile.file> then ipfs pin add <CidFromPreviousStep>. Ounce that’s done explore the CID to be sure. If you see the data then you can try Pinata and/or gateways.

Hi SionoiS,

I followed your steps and it seems to have done the trick. Looks like I was a bit ignorant, I followed the get started guide on the site but didn’t realise that it doesn’t automatically pin remotely. Looks to be working now – thanks so much for your assistance. I got a bit carried away with the file size too, as an aside.