How to add files that becomes "discoverable"?


I followed this Command-line | IPFS Docs

when I do ipfs --version ==>> ipfs version 0.9.1

I can open files ipfs cat /ipfs/QmQPeNsJPyVWPFDVHb77w8G42Fvo15z4bG2X8D2GhfbSXc/readme

I added a file ipfs add somefile.txt => added Hash…

but when In brave or from an other location I do ipfs:// that given hash, I cannot get it.

Why and how to fix this ?

note : I did the same with ipfs desktop mac => added a file, got a hash => impossible to consult via ipfs://

what step is missing ?

Did you run “ipfs daemon” to start the daemon?

I have “Daemon is ready”

when I do “ipfs swarm peers” => i get a list … /ip4/…

**** now it works, because I did ports 4001 and 5001 are open in out TCP

when I do ipfs add x.jpg => I get “added QmUpacEqSy8HbrHd1cZjFwWVVYFebNKapLEUHVnaRtzKL9 14607581321143.jpg”

now it works :wink:

the second image I added don’t work :frowning:

no error in the log shows :frowning:

added QmQLJYJ6N8PgMthdfv2BKhmvXQDDE5a14iBygUmTPsDQUz 14680590386372.webp

ipfs://QmQLJYJ6N8PgMthdfv2BKhmvXQDDE5a14iBygUmTPsDQUz ==>> is not accessible

what is going on ?

what could be blocking ???

Finally it works but it takes few hours to be “accessible”…

Check that your daemon can be contacted from the outside. If you are NATed, it won’t work so well. You may need to use a router that supports uPNP or open ports, or hardcode Announce addresses in the config.

ipfs id should show /ipfs/kad/1.0.0 among the protocols (not just /ipfs/lan/kad/1.0.0).


I have this {
“ID”: “12D3Koo…”,
“PublicKey”: “CAESIO…”,
“Addresses”: [
“AgentVersion”: “go-ipfs/0.9.1/dc2715af6”,
“ProtocolVersion”: “ipfs/0.1.0”,
“Protocols”: [