How can I run Freebsd version?

Perhaps this is something obvious, but apparently not for me :slight_smile: , so let’s get it thru

How can I run IPFS-Desktop (GitHub - ipfs/ipfs-desktop: An unobtrusive and user-friendly desktop application for IPFS on Windows, Mac and Linux.) on FreeBSD?


I believe all you need to do is download the FreeBSD package from where you linked and run pkg add ./ipfs-desktop-0.16.1-linux-x64.freebsd as root on that package. Let me know if that doesn’t work though, maybe I can get FreeBSD rolling and find out.

or perhaps @hacdias has pointers if they’re still around?

> sudo pkg add ipfs-desktop-0.16.1-linux-x64.freebsd
Installing ipfs-desktop-0.16.1...
pkg: wrong architecture: Linux:5:x86:64 instead of FreeBSD:13:amd64

Failed to install the following 1 package(s): ipfs-desktop-0.16.1-linux-x64.freebsd

Looks like we need something different. Thanks, anyway :slight_smile:

Haha wow that’s odd, the package says “linux”, when the extension is .freebsd. I’m going to open an issue about this…

Edit: Issue open: FreeBSD Package is ... Linux? · Issue #1877 · ipfs/ipfs-desktop · GitHub

@xliiv do you have Linux binary interop enabled?
See The FreeBSD Project | Chapter 10. Linux® Binary Compatibility

1 Like

Yes, I do. However, I’m still FreeBSD baby, so I might misuse it somehow.

> sudo chroot /compat/linux/ /bin/bash
bash-4.2# cd /usr/bin/
bash-4.2# ls -la ipfs-desktop-0.16.1-linux-x64.freebsd
-rwxr-xr-x 1 0 0 93065260 Jul 23 14:57 ipfs-desktop-0.16.1-linux-x64.freebsd
bash-4.2# ./ipfs-desktop-0.16.1-linux-x64
bash: ./ipfs-desktop-0.16.1-linux-x64: cannot execute binary file

(been a while since I had fbsd box around, this is from my memory)
Does marking it with brandelf help by any chance?

$ brandelf -t Linux ipfs-desktop-0.16.1-linux-x64.freebsd
$ ./ipfs-desktop-0.16.1-linux-x64.freebsd
1 Like

Says it’s not ELF…

> brandelf -t Linux ipfs-desktop-0.16.1-linux-x64.freebsd
brandelf: file 'ipfs-desktop-0.16.1-linux-x64.freebsd' is not ELF format

Just found an alternative to IPFS-Desktop… .


  1. Install IPFS-cli (
    sudo pkg install ipfs-go
  2. Run it
    ipfs init
    ipfs daemon
  3. Install IPFS-Companion (
  4. And mostly, that’s it… .

You can preview your node, by going thru these steps

  1. Click the IPFS-Companion extension icon in your browser
  2. Click “My Node” button

That’s it.

@Discordian @lidel thanks for your help
If you’d like to solve the original issue I’m willing to help. On the other hand, I’m satisfied with the ipfs-go + IPFS-Companion walk around.


Honestly if you’re developing (but it’s great no matter what), I personally prefer companion + go-ipfs anyways :D. Glad to hear you got a workable solution rolling. I’d love to re-install FreeBSD at some point tbh, I might do that in a couple months.