Ipfs couldn't resolve name

yesterday i published my site by ipns and it worked perfectlly(almost perfectly because sometimes there were some freezes when i tried to open it) but today when i try to see it i only can see info that “ipfs could not resolve name”. What is going on? Is my site missing after 1 day??

1 Like

DHT nodes will forget these records eventually. DHT nodes automatically expire all DHT records after at most 24 hours. And often already within 12 hours.

I agree, this is far from ideal. This is not IPNS related but DHT related. The only way to keep it up is to republish the IPNS record to the DHT every 12 hours for example…

Alternatively, we should solve this issue by using namecoin or pubsub to make it permanent.

EDIT: Thanks for using IPFS and to try to publish your site! Which is great news! I’m personally busy with a project to fix these issues to make IPFS more than just a distributed network file system.

The previous answer is correct, these records do expire and need to be republished every so often. Is your IPFS daemon still running? It should be automatically republishing IPNS records periodically.

1 Like