Ipfs name failing to resolve

both the cli, http api, and java api are failing to resolve my ipns name and it has been working fine for a week straight up until last night.

Have deleted my ipfs folder and reinitialized with ipfs init and still the new ipns hash cannot be resolved.

Any ideas on what may be going on or what I can do about it?

Have deleted my ipfs folder and reinitialized with ipfs init and still the new ipns hash cannot be resolved.

So you started over from scratch but even your new key doesn’t work? That’s… strange. When you do an ipfs name publish ..., do you see any errors? If you don’t mind, could you post your peer ID (the /ipns/ link)?

Its working now… maybe the DHT was way overloaded today and it was timing out?


^new id is now resolving


^old id is still not resolving (probably working as intended)

I did not change anything or publish anything to these namespaces today but ipfs name resolve is now working again in http, cli

still unknown on the java api but since the cli is working it probably is too

edit: java api is working as well

Yes. IPNS records expire every 24 hours (and are republished automatically every 12). If you stop publishing them (e.g., by not running a daemon or blowing away your local repo), they’ll disappear.


hmm thats weird i guess while i was working on it this past week i kept publishing to my namespace over and over refreshing my ipns record.

I did only try the new hash once or twice this morning so maybe it just timed out those times.

Thanks for this answer its good to know.

It should automatically be republished if you leave your daemon running. Were you doing that or just manually republishing.

This project was on my laptop and i had been busy with another project all day yesterday so This was exactly my problem, my daemon was offline for more than 12hours

I had first tried to load the page without the daemon running but then i ran the daemon and the page still wouldnt load

and then i tried to run ipfs name resolve -r on my desktop and it failed too for the same reason ( i had not run the desktop’s daemon in a week or so)

That’s because we start the republish timer at 0 when starting the daemon. This is likely a bug: https://github.com/ipfs/go-ipfs/pull/4440