IPFS Desktop with Synology

Is it possible to run an IPFS node on a Synology NAS with IPFS desktop?
I tried to move repository location from a laptop hard drive to the NAS but it doesn’t seem to work.

Not entirely clear on why it wouldn’t work, what specific issues are you running into?

It started to move files from hard drive to NAS without a problem and then, nearly at the end, I got an error message indicating that the move could not be completed. It had to do with ‘repo.lock’ if I remember correctly.

Note: IPFS desktop couldn’t start properly afterward as the original .ipfs was corrupted and files were missing. I had to recover everything manually by transferring back files from the NAS.

Are you trying to run an IPFS node on the Synology NAS or are you running the node on another machine and just using the NAS for remote storage after mounting a FS?

I have tried to move the repository location to NAS.

Filebase offers IPFS Pinning-as-a-Service, and is 100% compatible with Synology Hyper Backup.