IPFS Gateway Setup/Configuration Problems (Am I doing this right?)

Issue Getting Public IPFS Gateway Running

I have tried to get an IPFS Public Gateway working on EC2 using mainly one guide I found.

Like outlined in the Medium guide I used above, I followed the configuration exactly besides the number of small errors I outlined here and fixed within my configuration.

Everything installs correctly with the newest versions of IPFS. The ipfs --profile server initializes without issue.

  • The problem is a systemctl service that when I try to start, it gets stuck like what is outlined below.

All in all, I am just trying to get a semi-configurable public gateway working and I am wondering if there is a better guide or someone I can chat with to help steer me in the right direction. Also if there is a server configuration that works better, I am all ears to try that too.

After looking through a few Github issues, it does not seem there is a solution to the specific problem I am getting here, just some workarounds. I also reached out to the Medium articles writer to see if they had any recomendations.

IPFS Server/Node Configuration

1 Like

can you show journalctl -fu ipfs (you might need to page up and down) ?

1 Like

Does this help? Not very familiar with this command.

Looking at the guide you’re following, it seems that it has an error in the systemd unit file. Remove the space from -- enable-gc. Once you edit the unit file you will have to run systemctl daemon-reload to load your changes into systemd, after that run systemctl start ipfs (or whatever your unit file is named).

1 Like

Not directly related to your question, but you might find it easier to deploy an IPFS node to fly.io as explained in this guide: Deploying a Kubo IPFS node and gateway to Fly.io - YouTube

As for your question, it looks like we’re missing more of the logs to help.

The following command should return more lines to get a better idea of why it failed to start

journalctl --unit=ipfs-n 300 --no-pager
1 Like

Ohh wow I should have probably noticed that… trying this out now, thanks so much!

I tried the command you listed and this was returned-

I made a typo, there’s a space between ipfs and -n

journalctl --unit=ipfs -n 300 --no-pager COPYPASTA · Issue #3 · noryev/fenring-gateway · GitHub Awesome, here is the output. I am glad the age of this server was not older to make this log any larger.

So after going through this, this is what I get now…

Pretty strange… It now thinks that dash is in the wrong spot…

This is weird. Would it be possible for you to copy/paste the contents of the unit file? Not a screenshot, so that I can copy/paste it on my machine.

1 Like
Description=ipfs daemon
ExecStart=/usr/local/bin/ipfs daemon --enable-gc

I deployed with your guide and it took me 15 minutes. Thanks so much! Still going to try and figure out how to get it done on AWS. Such an awesome walkthrough, thanks a million!


I tried copy/pasting your command and it works, I was thinking that perhaps a weird character (an em-dash, nonbreaking space, something like that) had snuck in. From journalctl it would seem that it’s not recognizing the --enable-gc option, which is bizarre.

I’m wondering if there’s some control character in there that is not showing up in the copy-paste, otherwise I’m confused.