IPFS in Brave slows internet speeds to a crawl

Disclaimer, I’ve tried to get help for this issue on Brave’s forums with no luck.

I use the Brave IPFS integration along with its companion extension because right now, that’s all I really need for IPFS. Whenever I enable the IPFS integration on any mode except “Gateway”, it seems to slow my entire system’s internet connection to a crawl at random points, almost as if I’m getting swarmed by peers suddenly connecting to me. It would make sense if this only happened at startup but this happens randomly when I have it all enabled. This happens regardless of whether I use the IPFS companion extension or not. When I keep it enabled, it says that I sometimes have over 100 people connected to me, which makes me think this is a bandwidth thing.

I’d like to figure out if there’s a way to reduce/limit bandwidth or anything else that I can do to remove this problem because I’d love to not just be a leech through a public gateway and actually contribute to the IPFS network… but I won’t do that if it makes the internet unusable for me. Is there anything I can do? Thanks.

We have a tracking issue for Router crashes when Kubo is being used · Issue #9998 · ipfs/kubo · GitHub it contains two workarounds.

I hadn’t got report of this bug recently, would be nice if you could try the workarounds and tell us if it did anything. thx :slight_smile:

Okay now I can’t even visit that site in Gateway mode as it’s redirecting to an IPFS version through dweb.link. That’s odd, should I just try disabling IPFS in the browser in order to read about the workarounds?

I don’t get what you mean, which is “that site” ? Github ?

Yes, it was trying to route to the IPFS version of that page for some reason.

Anyways, I took a look at the recommendations but I’m not sure where I enter those commands? Like I said, I only use the Brave IPFS integration (with the companion extension) so I have no idea where to do it.

Github does not have an IPFS version.
I belive you can see the config with brave://ipfs, you will need to edit the JSON manually.

Hm not sure why it was trying to route through dweb.link then haha

Okay, I’m in that menu now but where do I find the JSON?

Also, I noticed that starting up my node resulted in a swarm of over 400 connections and it has been fluctuating up and down since. Is that normal?


Idk I havn’t tried brave recently. :cry:

Hm no worries, it’s not a big deal for me since I’ll just use a dedicated app for IPFS if I need to host. I just didn’t want to be a leech and only access files through a public gateway instead of contributing by hosting content. Thanks for trying!