Ipfs pin add slower before ipfs get

I have two nodes (my MacBook Pro and a Raspberry Pi) up and running, and in the same network. I have been experiencing that after a while (the Raspberry Pi is 24h/7d up and running) the command on the raspi to pin an object that has not been retrieved already, is slower than when getting it.

For example.

I have added on my Mac 6 files of about ~40MB each. I ssh into the raspberry pi and I perform

ipfs pin add $MagicHash

This command is really slow, and after 10 minutes I had to force close it. Tried again and again, and it was always slow. So I tried to get the directory:

ipfs get $MagicHash

And that was quite fast, since they are under the same network. So I then tried to pin it, with the same command, and this time it was much faster than before.

Note: On My raspberry pi I have pinned a lot of stuff, as also ipfs pin ls is quite slow.

Should I report this as a bug, with a ticket, or am I doing something wrong?

Ciao @koalalorenzo.
Sounds like an issue to report. I can’t see you’re doing anything wrong.

I had the same issue.