modified the DefaultPrefix, couldn't discover any nodes

I forked this project and modified the in , but after the modification, I couldn’t discover any nodes. Can you help me resolve this issue?DefaultPrefix dht_options.go,I have set up my own bootstrap node using the modified protocol. All my nodes are connected to this bootstrap node, but I can’t discover any other nodes.

You’re saying your modified nodes can’t discover eachother? Do they peer fine if you try to connect them manually?

I connected two nodes using the methods mentioned above, and then I tried to query the nodes using the method “peerChan, err := routingDiscovery.FindPeers(bp.ctx, bp.options.RendezvousString)”. I was able to discover each other, but if I don’t invoke “connectNode” method, I cannot discover each other. The modification I made was in the ”config.go” file under ”internal/config”, specifically in the variable DefaultPrefix, where I changed “/ipfs” to “/signipfs”, Currently, the bootstrap nodes I’m connecting to are the official ones: "/dnsaddr/", "/dnsaddr/", "/dnsaddr/", "/dnsaddr/", "/ip4/" . Should I provide my own bootstrap nodes and change the protocol to “signipfs”?

The GitHub address of my branch is“”。

I run two node in local network, two node in public network. and all node to connect my own bootstaps peer(hava public IP, source code: GitHub - BenDerPan/simple-bootstrap-node: A simple bootstrap node for kad-dht ( go-libp2p-kad-dht )).
local nodes can find each other, but local node can’t find public node. the public node can find each other,but public node can’t find local node.