New IPFS cluster not connecting with existing IPFS cluster


Initially, I provisioned 4 IPFS clusters and it was working as expected. After a month when I created a new node and tried to connect with the existing IPFS cluster, I am unable to connect. Providing cluster peers list as screenshot reference.

In the new IPFS cluster logs, I could see the below errors
DEBUG raft raft/raft.go:284 12D3KooWJKMHUBbZwByPYXd7V8oqCDv5eR6zy8f85YhCfiqTUXMt: get configuration
2023-06-07T13:17:54.758Z DEBUG raft raft/raft.go:293 12D3KooWJKMHUBbZwByPYXd7V8oqCDv5eR6zy8f85YhCfiqTUXMt: not voter yet

Are the other peers using Raft too?

How did you add the new node? With Raft, iirc, you have to use --bootstrap when launching.

See Peerset management - Pinset orchestration for IPFS


Yeah, I have used the Raft mechanism for all the peers setup and also used the --bootstrap method for the connection establishment

Raft is mostly legacy at this point, but usually, make sure the new peer is not in the old peerset (peer rm if it is). Re-bootstrap it to it. Verify same secret and connectivity to the others. It would seem the Raft cluster is not committing the new member for some reason. You have to check the logs for the other peers, particularly for the Raft leader.

I tried the given steps earlier and checked the secret in all the nodes it is the same. Still, the issue is persisted. I have attached the logs here

Does the rest of the cluster have 50%+ of members online? The Raft consensus needs to be operative to accept new members.

Yes all the members are online

Run with --loglevel raft:debug on all peers and see whether there is more information about committing the new peer.