Private IPFS network set up between laptop and desktop, but AWS node will not connect or see peers

I have a private ipfs network set up and working between 2 ubuntu vms on my laptop and desktop with the desktop being the bootstrap node. I’m attempting to set up ipfs on an AWS server running Amazon’s linux 2 instance where I would just add the desktop as the bootstrap node (because I know it works) and run it from there.

When I run IPFS daemon as I would normally between the 2 nodes this is what appears on the server side - for some reason there’s no “swarm announcing” as there is on my bootstrap node

This is what my config looks like after changing the IP address for gateway and api as well as hard coding in “Announce” to no avail. - ive tried it with and the IP address of the AWS instance and neither work

I’ve also added some rules to the security group to hopefully avoid those issues which is below

Finally, I ran IPFS daemon in the background and attempted to manually connect to the bootstrap node using “ipfs swarm connect " and it returned " no good address”

Thank you so much in advance:)

I see at least 3 problems at a glance:

  • is a private address, it cannot be routed to the public internet
  • /ip4/ actually blocks it from being announced
  • your bootstrap address is a private address

Thank you so much,
One quick question, the first two should be easy enough to fix in AWS settings and the config file, but would I need to change the IP address of my bootstrap node entirely? The only reason I ask is because that bootstrap node worked previously with a separate machine running ubuntu.
Again, Thank you so much for your help

your main issue is that your desktop machine isn’t reachable from the internet, and therefore only announces a private address. since your laptop is on the same LAN, that’s good enough for it. However, AWS is across the internet, so that can’t work. You need to set up port forwarding on your router to expose your desktop, at which point it will start to announce both a private address and a public address. Then, change the bootstrap address on AWS to your desktop’s public address, and run it, it should connect successfully.