Resource temporarily unavailable after idle

Hi, I am trying to build ipfs from source. I have been cloning from the go ipfs repo, and use the make file to make install. I have tried this on 2 different machines and 2 different network connections. Initially everything works great, I can pin my files and cat files from others, but eventually they get resource temporarily unavailable error when ipfs cat CID from terminal. The daemon stays alive and I can still interact with it through the webUI, but terminal stops working and show the error. Another weird thing is that when that happens, my internet connection seems to be weird. I would not be able to access some sites until I restart my computer.

Is this a konwn issue? Or am I missing a step to get it working?

If it helps, these are the versions I am running on
Go: 1.14.6
go-ipfs: 0.7.0
OS: Ubuntu on a Windows linux sub system

Thanks you :slight_smile:

Might be your router dying because it’s having to manage too many connections or has bugs in upnp etc. Try reducing the swarm settings (HighWater, LowWater) in the config and see if things improve.

I ran it on a mac instead of an Ubuntu sub system on Windows and it was fine… Seems like running on Windows Linux subsystem was the issue.