Content only Available via certain Public Gateways?

I’m been attempting to evaluate IPFS with some varying results. I’ve installed a node and following the documentation, added the “meow” test file which I successfully pulled via the gateway. So, moved on to trying the single webpage example. This time I couldn’t retrieve the file even after waiting for long periods of time. I tried some of the suggestions for opening up port 4001 (I’m behind a router). Finally I just moved the Macbook to dmz, exposing all ports. The diagnostic tools, PL Diagnose and IPFS Check pass all checks, but still I can’t access the content via gateway. Thinking maybe there’s an issue with the gateway I went to the Gateway Checker page where I got the idea to try some of other gateways. Here I found some success: - 504 Gateway Timeout - 504 at first, then worked!
cloudfare - works
cf-ips - works
runfission - 404
4everland - 403
trustless - 406 Not Acceptable
pinata - “only html that is pinned to Pinata…” (ok, fair enough)
ips.eth.aragon - works - works - works
hardbin - timed out

So, my question is what would account for certain gateways working and others not? It seems like the is the goto gateway for checking content availability and this just wont work for me. I’m copying the “share file” link from the app:
The file is also pinned locally. Using Desktop app for Mac.
My PeerId is 12D3KooWAYhA2VUBRxFvRws76wqMdH8Q3613RkAUZUxwAbC3675V
At last check, says I’ve discovered 800 peers. Thanks in advance.

Yeah we need to remove fission from that list. Also only shows content pinned by users of our service.

FWIW your link works for me. It shows source of the HTML rather than rendering it but it does show.

Yeah, I was wondering why it didn’t render the html but one thing at a time…Since you were able to fetch my CID, I got the idea that it must somehow be related to location or IP address? I tried using my phone, this time shutting off wifi and using LTE - it works. Then I turned on the VPN, picked some random US server and it now works via my desktop (the macbook running my ipfs node is not on VPN). So, maybe this is be design, that it won’t fetch content back to the origination IP?