Corrupt Firefox add-on

I am trying to install IPFS on my laptop. I have installed IPFS-Desktop but when I try to add IPFS-Companion to my Firefox I receive this message: “Installation aborted because the add-on appears to be corrupt”.

It’s version 2.19.1, last updated July 1, 2021. How do I solve this problem? Thanks.

Hey Paulo,

Couple questions that can help us diagnose what’s going on here:

  • what version of Firefox are you installing in?
  • Are you building the extension yourself or installing from


Herewith info requested :

a) Version of Firefox: 102.0.1

b) I’m attempting to install from

I was unable to reproduce in 102.0.1, nor 103. Perhaps some bits got flipped on your disk and corrupted the download? Are you installing from IPFS Companion – Get this Extension for 🦊 Firefox (en-US) specifically?

@Paolo_R do you mind trying to:

Updated to 103. Using the link, I still get the ‘add on corrupt’ message.

Just a thought - I have a few Firefox security and privacy add ons installed e.g. NoScript, Privacy Badger, Ad Blocker, Duck Duck Go Privacy Essentials. Could one or more of these be causing the problem?

No, other extensions should not be able to do this.

Are you able to install it on a new, empty profile?

Potential causes:

  • damaged download is stuck in ~/.mozilla/firefox/.. cache somewhere (if running on empty profile works, then you confirmed this is the problem)
  • some third-party software messing with your HTTPS traffic (are you running any third-party antivirus/firewall on Windows?)


I’ve tried with a different profile but no effect. I use ESET anti-virus but I’ve also tried with it deactivated - no effect. Also restarted Firefox with add-ons deactivated - no effect. :frowning:

A stab in the dark, but is the clock / date in your system correct?
Firefox requires extensions to be signed and if your system time is invalid, signature verification may fail.

Yep, clock and date are correct.

Incidentally trying to access via my web browser gives a message saying that the site cannot be found. I’ve tried Firefox and Chrome.

It sounds like something messing up with your internet. is often blocked by antivirus software, could be your ISP too. I know you said you’ve disabled ESET, but did you reboot after making that change? Or perhaps you have something else installed for protection?

You could try to boot from some Linux livecd/liveusb to see if the problem goes away
(to confirm it is Windows software on your box as the source of the problem, and not your ISP).

I’ve got and in my ESET whitelist. is accessible but I get the ‘unable to find site’ for The only other protections I have are add-ons like NoScript, Privacy Badger etc. is fine - no problems accessing which this thread seems to be hosted on.I’m not sure where the came from??? So access problems seem to be over.

Just can’t add IPFS-Companion to Firefox. I don’t have this problem with any other add-ons, nor doi have web access problems.