At this moment I am running several IPFS websites and they all work fine, however, I keep receiving an ERROR message (see screenshot) over and over again. I tried to lookup how to keep the TCP alive or solutions regarding the setsockopt but unfortunately I am not experienced enough to find a solution for this problem. I hope someone knows which steps (as exact as possible) I should take to resolve the issue.

Thanks in advance!!

1 Like

Can you give us more info on your system and ipfs node (OS, arch, go-ipfs version, etc…)

Heey @fusetim thank you for your reply. I am sorry I forgot to mention this:

Operating software: Mac OS Mojave, version 10.14.6
go-ipfs version: 0.9.0
System version: amd64/darwin
Golang version: go1.16.5

Unfortunately I don’t know how to find the architecture type but if it is necessary please let me know
how to find it

No worry you just gave it: amd64/darwin

1 Like

Interesting, I wonder if other OSX users see these errors. Did they just start with v0.9.0? If so, what version did you have before you saw these messages?

Heey, @Discordian before I had these messages I had version 0.6.0. Maybe it is just my computer, that I have certain settings that I don’t know off that create those issues.

1 Like

This change was introduced in 0.9.0. We enabled TCP keep alive to more quickly detect stalled connections.

It sounds like the connection may be dead at this point? We should probably just ignore that error and move on.

1 Like
1 Like

I am getting the same error. @PDennis were you able to find a fix for this?

Some info:
Operating software: MacOS Moneterey, version 12.2
go-ipfs version: 0.11.0
System version: amd64/darwin
Golang version: go1.17.3

I also got the same error. My solution was to simply open port 4001 for both TCP and UDP, instead of port-forwarding to a specific local node.

In the NAT configuration of my router, I noticed that port ‘4001’ pointed to the IP address of the old node. I assumed the returned “keep-alive” signal was directed to the old node instead of the current node, resulting in an error.

So I removed the port forwarding NAT entry and simply opened 4001, and when I restarted the “IPFS daemon”, the error was no longer present.

Hope this helps somebody!

  • OS: macOS High Sierra 10.13.6
  • go-ipfs version: 0.12.0
  • Repo version: 12
  • System version: amd64/darwin
  • Golang version: go1.16.12

I got the same error but I solved it.


ipfs cat /ipfs/<your key>/quick-start


ipfs daemon 

Open another terminal and input the command,

ipfs daemon 

Then, come back to original terminal and input

ipfs swarm peers

you can check this link!