Trouble installing with Mac Air OSBigSur


I have some trouble installing ipfs on my macbook air. I’ve followed the steps but it seems my mac does not have certain write permissions. How can I move forward?

Ive tried deleting go-ipfs/ folder and unzipping again and trying to install again. i also tried sudo bash install but no luck.

See attachments and thank you!

You need root permisions to install IPFS like that (if you want there are ways to run IPFS without but it’s not what ./ is able to do).

Perhaps try running this script as a privilged user:

sudo ./

Have you tried that, does that work ?

Same error.

It suggests i run sudo ./ instead (which is the same code i ran)

That very weird, with root permission you should be able to do anything.
Can you pls show the result of this :

sudo whoami
file ipfs

I’m surprised it seems your root user is not allowed to access /usr/bin
Can you show

ls -dl /usr/bin/
ls -dl /usr/local/bin/

pls ?

BTW are you running an M1 mac ?

yes its a m1 mac

Screen Shot 2021-11-14 at 12.30.19 AM

thanks again

Honnestly I don’t really know why.

The root user is allowed to write to /usr/bin, it should work.

I see you have used the x86_64 binary, I know it should work because of apple’s emulation layer but for performance reason always use the non emulated native (here ARM64) version :

Appart from that I don’t really know, it should work.
You can just use IPFS in “portable mode” just use it with ./ipfs.

i tried using the arm64 version but no luck…

how would i go about starting ipfs in portable mode?

Just extract and do ./ipfs